End of sequence abort

Is there a way to stop the automatic count down when a sequence aborts or finishes its sequence?

Often I will move onto another target and will wait until an issue is resolved, it drives me up the wall that if I don’t uncheck the sequence end option that it will start the end process.

I have checked the help files and can only find what to do and how many attempts and the duration, nothing about telling it to maintain the current equipment status.

Appreciate a response.


There is an option in the sequence box, to leave on/ turn off equipment at end of sequence.

Thanks Buzz,

There is an option, but maybe the wording is wrong because it says show an option to skip gear shutdown for X secs.

If unattended I don’t want it to shut down at al: -


I tried that option last night and it doesn’t prevent the equipment from being disconnected.

@Jared can you advise how to stop this automatic disconnection of the equipment as I cannot find anywhere that allows one to disable it.

You’ll want to disable this option for your sequence:


Superb thanks Jared, I could not find anywhere to disable that.

Is there a way to permanently disable it?

It is not enabled by default. So that means you either enabled it in your profile that created the sequence or you enabled it in the sequence. It is not a “system level” setting.


OK Jared, I am just about to plan a new target this evening and will check whether by default it is there or not and advise.


Hi @Jared ,

As advised I checked to make sure it was not enabled and I never have enabled it as up until your post I didn’t know where that was hidden, so here is the proof before I started my session: -Proof not enabled

And this is what happened at the end of the session: -

So it looks like there is a bug as there is no other way as far as I know to stop it doing it.

Please can you advise?

Many Thanks,



@Jared Sorry but no reply to the above and it happened again last night

More Proof it does shut down

It is definitely not enabled where you thought it was and really does need rectifying.


I don’t see the big problem in SGP parking the gear when it’s finished? This is a very important safety feature that as far as i know cannot be turned off unless you manually untick the "run end of sequence options)

The box mentioned here is for disconnecting the gear after it has parked, it does not influence the parking of the gear.

What you could do thou is stop the mount from parking at “end sequence”, but why would you turn of such important safety measure? The only reasoning you mention is that it’s annoying and in my opinion safety is more important than something being annoying because you don’t use the options in the software right…

In my opinion what you really should use is automatic pause after an event, this pops up a box that will pause till you click the box

Thanks for the reply, but you are missing the point, if recovery fails for example it loses a star or similar reason to abort then it disconnects the equipment, which I most certainly do not want it to park and disconnect.

Or it maybe that I want it to continue on a target from a previous session, so why would I want it to park?

It should be for the user determine when it wants to end and not to be shut down without a choice.

I have a Lunatica Cloud Control System that will shut down my Dome Observatory should the weather become inclemental.

My issue is as previously mentioned, there is no way to stop this from shutting your equipment down unless you have the good fortune to catch the pop up window and uncheck the box in time!

As already pointed to, if you disable the option “Disconnect all equipment at sequence end” SGP will not shut your equipment down at the end of a sequence.

If you also disable the option “Park when sequence completes”, SGP will not park the scope at the end of a sequence.

Kind regards,

You haven’t mentioned a single word about recovery earlier so the point you say i missed wasn’t mentioned at all.

Since you have a safety system and you setup SGP correctly it will pause while “unsafe” and continue when it’s safe again, i’ve used this for years and also setup the same for 4 setups.

I can start the setup while it’s unsafe, SGP just waits and waits till it’s either safe or the end of sequence time is reached and turns of the equipment with a script.

Hi Horia,

Please read my comments that option is not working,m thus the screen captures and my reason for reporting it, it doesn’t work on any of my systems.

Hi Xplode,

As I have said to Horia the system does not work as per the screen captures and my first line of my first post said: - “Is there a way to stop the automatic count down when a sequence aborts or finishes its sequence?”

To my mind aborts/recovery are in the same theme.

To me it seems everything works as it should, it’s more like user error where you don’t understand how everything works together or you want to use SGP in a weird way that would require customizations just for you.

Absolute garbage Xplode, what give you the right to be rude to me, I haven’t been rude to you!

It does not work as it should as when Jared pointed out what was needed to be done has no affect whatsoever.

I don’t see how it’s rude to point out that it’s user error/missunderstanding how things work? (in fact user error is very common for something as complicated as astrophotography with all the different software, drivers and devices needed to work together)

It’s very hard to help you when you don’t write the exact problem and circumstances, you’re leaving out things like wanting to use recovery mode and having a safety system.
You also say SGP disconnects the gear after recovery fails, without the “disconnect all equipment at sequence end” it will normally not disconnect, i cannot see a logfile to prove your claims either.

It should be for the user determine when it wants to end and not to be shut down without a choice.

It is up to the user to detemine this, but remember that you need to configure SGP to do whatever you want, within SGP’s limit of course.

Setting up SGP with a safety system and with recovery mode to work 100% is not an easy task to do for most people, it honestly took a long time for me, it wasn’t easy and there was a lot of testing and failing before it worked stable.

People here will gladly help you with the required settings to run unattended, but it’s impossible when you give so little info about your setup and how you actually want to do imaging.

Xplode, I am getting nowhere with you and would ask that you refrain from replying as you obviously don’t have the capacity to understand the issue.

I am not a beginner and have a good few years experience, so don’t try to preach when you don’t understand the problem. I am always ready to accept when I am wrong and apologise, but in this instance the suggestion from Jared is not working.

Just for others I will spell out the problem and the issue.


SGP at the end of a sequence or if the sequence aborts due to a lost star, will bring up the recovery dialogue box as per this image: -


Jared replied to say that this can be disabled if you uncheck this box as he thought I may have enabled it, but the fact is I haven’t and never have enabled it: -

This was the capture before commencing my sequence, clearly showing that I have not enabled the setting: -


Why I want to disable it

I have a cloudwatcher system that watches any potential bad weather, this is the link: - https://lunaticoastro.com/aag-cloud-watcher/

Currently as I am unable to disable the shutdown and disconnection of my equipment, it means recommencing cool down etc.which I do not want to happen, there is no reason to disconnect the equipment with my settings, so I want to disable the function, but the function shown does not work.

Another reason for wanting it to function correctly is that frequently I will do my flats at the end of a session, so why switch things off when I need to continue using the equipment.

That is the issue, purely and quite simply a function within SGP does not work as intended, end of.