Erronious "Sequence Complete" message directly after sequence start

Why does SGP report “End Of Sequence” right after a sequence has started? No imaging has started and there are clearly active targets to be run.

Link to Logs

Approx time of issue: 00:03

Useful Info

OS: Microsoft Windows 11 Pro
Ver: (64-bit)
.NET: 4.8

Looking at the SGP log with fresh eyes this morning, it seems to me that the immediate “End of Sequence” problem is related to the error message “Could not open shutter” (See extract from log below). My observatory shutter is opened manually, and should not be controlled by SGP. I have not found a way to configure this fact in SGP. In previous versions of SGP, this message has only been a warning and has not stopped the sequence, but now this has apparently changed and has become a show stopper for me. I cant get a sequence to start.

[09/15/23 00:04:28.597][DEBUG][Sequence Thread][SQ;] Sending Notification: Status - Sequence has started…
[09/15/23 00:04:28.611][DEBUG][Sequence Thread][SQ;] Camera reports temperature is already within range, cooldown not started again.
[09/15/23 00:04:28.612][DEBUG][Sequence Thread][SQ;] Checking if observatory requires auto slaving…
[09/15/23 00:04:28.612][DEBUG][Sequence Thread][SQ;] Attempting to auto slave the observatory…
[09/15/23 00:04:28.614][DEBUG][Sequence Thread][SQ;] Auto slaved the observatory…
[09/15/23 00:04:28.617][DEBUG][Sequence Thread][SQ;] Attempting observatory startup…
[09/15/23 00:04:28.617][DEBUG][Sequence Thread][SQ;] Observatory startup failed, could not open shutter!
[09/15/23 00:04:28.617][DEBUG][Main Thread][SQ;] Adding sequence level notification: Observatory startup failed, could not open shutter!
[09/15/23 00:04:28.652][DEBUG][Sequence Thread][SQ;] Sending Notification: Error - Observatory startup failed, could not open shutter!
[09/15/23 00:04:28.667][DEBUG][Sequence Thread][SQ;] Sequence aborted during observatory startup…
[09/15/23 00:04:28.668][DEBUG][Sequence Thread][SQ;] Set sequence abort
[09/15/23 00:04:28.668][DEBUG][Sequence Thread][SQ;] AbortSignal “Global Abort Signal” set to True by Sequencer.SetSequenceAbort
[09/15/23 00:04:28.825][DEBUG][Sequence Thread][SQ;] ********* Run post sequence *********


Thanks for looking into this

You are saying here that you do indeed want the dome to be slaved to the scope for normal movements, just that you don’t want SGPro to try and open the shutter (because it’s a mnaual operation)? Or are you saying that you don’t want the observatory slaved to scope at all?

Hello Ken,

It is correct that I do indeed want the dome to be slaved to the scope, this is absolutely necessary. It’s just that my dome shutter operation is not automated (Im running a Pulsar Dome and I did chose not to include this option). I’m manually opening the shutter at the beginning of the night and closing it at the end.

This has worked quite well for me for the past 2 years using SGP, until now.


I was in no way implying that it wasnt, just making sure I understand the report. The sequence included in the logs seems not be using the telescope slaving option at all. It’s just disabled. Can you either provide access to the sequence that is using slaving or send screenshots of your slaving configuration?

That is strange. I did create a new, one target, sequence to see if it made a difference. It did not, the problem remaind. The log is from this sequence. Here is a screenshot of the
slaving options for the sequence I ran when I first got this problem:.


My workaround at the moment is that I have reverted back to version which was the last version I know worked for me and it still does. The “could not open shutter” message is just a warning, but the sequence continue to run without problem.

There seems to be another similar report here:

Observatory startup failed, could not open shutter (NexDome controller used) - Sequence Generator / SGPro Support - Main Sequence Software (

I am not 100% certain that it is the same issue, but it’s too similar to ignore. I’m taking a look.

1 Like

If SGP could just go back to giving a warning instead of an error that would be all I need. I had been using SGP v3 for the past few years with no issues beyond the warning message. I may attempt that earlier version 4 until this gets resolved.

Thanks for the tip on the most recent working version. I’ll download that and give it a shot tomorrow.

That other link is mine.

I think this release will address the issue:

Sequence Generator Pro is Released for General Use - Releases - Main Sequence Software

That did it! Thank you for the quick response!!

I can confirm that the .1147 release fixed the problem.

Thank you