Observatory startup failed, could not open shutter (NexDome controller used)


I built my own dome and automate it with a controller and motor from NexDome. My shutters are fully manual and I don’t intend on automating them. When I try to start a sequence with SGP 4 it fails at startup because it cannot open the shutter.

How do you tell SGP to ignore a shutter? At this point SGP is useless if I cannot get past this failure.

Link to Logs

Useful Info

OS: Windows 10

I saw you post on the FB group. I also have the original controller. In the ASCOM driver, there is a box you should have unchecked “Enable Shutter Control”. That should fix the issue I believe.

Hi. Thanks. I have tried that box checked and unchecked. I still keep getting the same error in SGP.

There is another similar report to this also. If you can provide logs with the failure, I may be able to track down what’s happening.

If you’d like to provide a log to show what is happening, we’ll be able to provide additional assistance. Further guidance is here:

1 Like

I will get the log file when I get home from work tonight. Thank you.

I set up a quick test to demonstrate the problem. I am running a NexDome Arduino controller to control my homemade dome. It works fine, the dome rotates in sync with no problems when I manually select a target. But when I enter everything into SGP (which I’ve used for years but just recently upgraded to v4) it complains about the subject error of not being able to open the shutter. My shutter is fully manual. The NexDome control software that I am using is: NexDomeControlSystem v4.0.0. There is a check box that either enables or disables shutter control (which I have tried both ways with no success in SGP). It just seems as if SGP is not seeing a toggle of some sort to ignore the shutter and instead sees it as an error.

The time of the error in this test is around 21:27.

Link to Logs

Approx time of issue: 9:25 PM

Useful Info

OS: Microsoft Windows 10 Pro
Ver: (64-bit)
.NET: 4.8

I think this release will address the issue:

Sequence Generator Pro is Released for General Use - Releases - Main Sequence Software

That did it. Thank you!