Error detail: El servidor RPC no esta disponible, excepción de HRESULT: 0x800706BA

Hello everyone, I am writing in the hope that someone can help me.
I am new to SGPro and when installing and running it I repeatedly get this error. I have searched for information, I have changed system configuration, the RPC is running, I have installed different versions of SGPro and I always get the same error. I’m running it on a Windows 11, I’ve tried 32 and 64 bit and still the same. I would appreciate help to resolve the error.
Thank you very much.

I would need to see the logs to be certain, but I think that error message is coming from one of the ASCOM drivers and not from SGPro. It typically means that there is a 32 / 64 bit driver mismatch, but since you have tried the 32-bit version and still see the same issue, it likely means that ASCOM cannot find the information it needs from the Windows registry. I can’t be certain of the fix here, but in your place, I would:

  • Make sure ASCOM is up to date with the latest version
  • If it already is, uninstall and re-install it
  • For any ASCOM equipment that you are using, do the same, uninstall and re-install
  • Make sure to continue using 32-bit SGPro unless you know for certain that all of your drivers are 64-bit compatible.

Here is instructions on submitting logs so we can maybe provide additional guidance:

Good morning, thanks for a quick response, I have already uninstalled Ascom and reinstalled it and it still gives the same error.
I only have to reinstall 1x1 the device drivers.
Because if it doesn’t work, what solution could I have?
I finally decided to buy the license and when I started to configure this fatal error has come up and I will not be able to have SGPro.
I’m waiting
Thank you very much
All the best

The error is coming from ASCOM so we don’t have much insight into it. If you provide logs, we might be able to tell you specifically what device is problematic. In any case, the first step will be to contact the driver’s author to see if they have any suggestions. That said, if you are unable to get SGPro to work for you, we don’t have any issues providing a full refund.

From the logs in the other post, it seems that this is the driver issuing the error:

Making ASCOM switch: ASCOM.RBFocusPowerController.Switch...

You can verify this by uninstalling that driver complete and then attempting to make and load a NEW equipment profile without any references to that switch driver.

Very true, there was the error.
Thank you very much