Failure with Local Plate Solve (ANSVR)


I’m on my second night trying to understand SGPro. I am at this moment trying to get blind Plate Solving to work,

I think my problems are Windows 10 related. I am usually a Mac person.

My image is 30 minute sub, 3354 X 2529 pixels, taken with an Atik 383L OSC camera.

I have used “ansvr-setup-0.18” to install ANSVR on the C: drive.

  1. With my WiFi turned on and “Astrometry,NET(Remote)” selected in the Blind Settings->Plate Solver Options box, my image solves in 51 seconds

  2. With my WiFi turned on and “ANSVR(Local Astrometry.Net)” selected in the Blind Settings->Plate Solver Options box my image doesn’t solve. The status bar says, “Uploadiing and solving (waiting on ANSVR). Elapsed time …”

Any suggestions would be very welcome!


This is what the ANSVR log looks like when I start up SGPro:


Post all of your logs please :blush:

You might have another program running on that port 8080…

Have you tried rebooting the entire machine?

Here’s another thread with a similar issue: local solver - Plate Solving - Main Sequence Software

1 Like

Could also be firewall…

1 Like

I’ll second that. Either some other application is using that port or maybe you have 2 instances of ANSVR running? Maybe @Andy can chime in.


I am starting to feel like an idiot. *Actually a 71 year old idiot) I just can’t get the plate solving to work locally.

I do think I have the ANSVR working. Here is the log:

[2016-08-28 18:49:42] ansvr 0.18 start
[2016-08-28 18:49:42] using default config settings
[2016-08-28 18:49:42] read port 7900 from reg
[2016-08-28 18:49:42] using scale error override value 5 percent
[2016-08-28 18:49:42] using downsample 2
[2016-08-28 18:49:42] solution coordinates will use epoch J2000
[2016-08-28 18:49:42] saving config to /var/tmp/platesolve/config
[2016-08-28 18:49:42] [Server /opt/ansvr/ansvr accepting clients on port 7900]
Waiting for data… (interrupt to abort)

Note that I changed the port to 7900.

When I change the Blind Solve to ANSVR(Local Astrometry.Net) and click settings, I get a browser window with this message:

This site can’t be reached refused to connect

In the address bar I see:

This suggests to me that SGPro is not aware of the new 7900 port location.

Am I missing a setting somewhere?

I appreciate all the help that’s been offered. I think I’ve tried every suggestion.


Have you told SGPro that you are running a non-standard setup? You cannot pick ANSVR from the list because it assumes a standard setup at port 8080.

Looks like there is a small bug to fix in that you have to enter that and then click OK, then open it again before clicking settings.

Thank you Ken for helping me. I think I almost got it working. I changed the setting to your address and after a few clicks, I would get the configure page every time I clicked setting. I tried a solve and it seemed to hook up, but it didn’t solve. I have not been able to get back to that state since! Here is what the log says. It stays the same even when I do a restart?

[2016-08-28 21:48:43] POST /api/submissions/4 HTTP/1.1
[2016-08-28 21:48:43] SUBS: solve is not done yet
[2016-08-28 21:48:43] SUBS: jstr: {“user”:“0”,“processing_started”:“1”,“jobs”:[],“processing_finished”:“0”,“user_images”:[]}
[2016-08-28 21:48:44] POST /api/submissions/4 HTTP/1.1
[2016-08-28 21:48:44] SUBS: solve is not done yet
[2016-08-28 21:48:44] SUBS: jstr: {“jobs”:[],“processing_started”:“1”,“user”:“0”,“processing_finished”:“0”,“user_images”:[]}
[2016-08-28 21:48:45] POST /api/submissions/4 HTTP/1.1
[2016-08-28 21:48:45] SUBS: solve is not done yet
[2016-08-28 21:48:45] SUBS: jstr: {“user”:“0”,“processing_started”:“1”,“jobs”:[],“processing_finished”:“0”,“user_images”:[]}
[2016-08-28 21:48:46] POST /api/submissions/4 HTTP/1.1
[2016-08-28 21:48:46] SUBS: solve is not done yet
[2016-08-28 21:48:46] SUBS: jstr: {“user_images”:[],“user”:“0”,“jobs”:[],“processing_started”:“1”,“processing_finished”:“0”}
[2016-08-28 21:48:46] POST /api/cancel/4 HTTP/1.1
[2016-08-28 21:50:26]
[2016-08-28 21:50:26] serve notfound uri =
[2016-08-28 21:50:26] [Connect from]
[2016-08-28 21:50:26] GET /api/config HTTP/1.1
[2016-08-28 21:50:26] [Connect from]
[2016-08-28 21:50:26]
[2016-08-28 21:50:26] serve notfound uri =
[2016-08-28 21:50:26] [Connect from]
[2016-08-28 21:50:26]
[2016-08-28 21:50:26] serve notfound uri =
[2016-08-28 21:50:26] [Connect from]
[2016-08-28 21:50:26] GET /api/config HTTP/1.1


I re-installed ANSVR and entered “” under Blind Solve. When I now click Settings I get the a browser with the configuration page. When I Right Click on my image and do a Blind Plate Solve it just runs and runs. I’d appreciate your help. This is the log:

[2016-08-29 09:27:24] POST /api/submissions/7 HTTP/1.1
[2016-08-29 09:27:24] SUBS: solve is not done yet
[2016-08-29 09:27:24] SUBS: jstr: {“user_images”:,“processing_started”:“1”,“jobs”:,“user”:“0”,“processing_finished”:“0”}
[2016-08-29 09:27:25] POST /api/submissions/7 HTTP/1.1
[2016-08-29 09:27:25] SUBS: solve is not done yet
[2016-08-29 09:27:25] SUBS: jstr: {“user_images”:,“processing_started”:“1”,“jobs”:,“user”:“0”,“processing_finished”:“0”}
[2016-08-29 09:27:26] POST /api/submissions/7 HTTP/1.1
[2016-08-29 09:27:26] SUBS: solve is not done yet
[2016-08-29 09:27:26] SUBS: jstr: {“processing_started”:“1”,“jobs”:,“processing_finished”:“0”,“user”:“0”,“user_images”:}
[2016-08-29 09:27:27] POST /api/submissions/7 HTTP/1.1
[2016-08-29 09:27:27] SUBS: solve is not done yet
[2016-08-29 09:27:27] SUBS: jstr: {“user_images”:,“processing_started”:“1”,“jobs”:,“user”:“0”,“processing_finished”:“0”}
[2016-08-29 09:27:28] POST /api/submissions/7 HTTP/1.1
[2016-08-29 09:27:28] SUBS: solve is not done yet
[2016-08-29 09:27:28] SUBS: jstr: {“user”:“0”,“jobs”:,“processing_finished”:“0”,“processing_started”:“1”,“user_images”:}
[2016-08-29 09:27:29] POST /api/submissions/7 HTTP/1.1
[2016-08-29 09:27:29] SUBS: solve is not done yet
[2016-08-29 09:27:29] SUBS: jstr: {“user_images”:,“processing_started”:“1”,“jobs”:,“user”:“0”,“processing_finished”:“0”}
[2016-08-29 09:27:30] POST /api/submissions/7 HTTP/1.1
[2016-08-29 09:27:30] SUBS: solve is not done yet
[2016-08-29 09:27:30] SUBS: jstr: {“user”:“0”,“jobs”:,“processing_finished”:“0”,“processing_started”:“1”,“user_images”:}
[2016-08-29 09:27:30] POST /api/cancel/7 HTTP/1.1
Waiting for data… (interrupt to abort)

Hi Robert,

Sometime ago I also had an issue with ANSVR and got two tips which actually where right on the mark. Please have a look at this thread:



It’s possible there is a bug in SGPro with custom setups, but I would look at your local setup to ensure you have all the appropriate Astrometry.NET indexes installed for your gear before we go down the other path.


Thank you for pointing out your “threat”. I’m down loading the additional index file now. Hopefully I’ll have better luck!


I’ve been downloading additional indexes since noon. Wow, that’s a lot of data. Hopefully it will help! Thanks for your input.

I have one additional question I’d like to ask. The first step I do with my setup each night is to calibrate on a bright star. I aim my scope with the finder and take an image. Then I draw a “subset” box around the star and the center of the crosshairs. I then set my camera to take repeated images and move the star onto the center of the crosshairs and then re-calibrate the mount. (this is with Artemis software (Atik), I tried to do this with the “Frame and Focus” module, but it wouldn’t work. The crosshairs repositioned themselves in the subset box. Am I missing something here?

Thanks for your response. Very pleased with SGPro.

Keep in mind that having too many indexes can sometimes lead to long solve time (or at least long failure times). Finding the ones you actually need is your best bet here.

Apologies, but I’m not understanding the question. You have detailed a set of steps but it’s not entirely clear to me what you are trying to do or why aborting the finder and just using a blind solve and sync solution is inadequate.

You’re so right. I’m just stuck in my old ways. Plate solving solves everything. Sorry for asking such a dumb question!

I am pleased to say that I just purchased a copy of SGPro.

I have had some success with plate solving, but still can’t get ANSVR to work. I am attaching a text
file with a step by step description of my success and failures. I did download the entire ANSVR catalog.

I hope you can help me solve my problem.

Plate_Solve_Experiments.txt (5.1 KB)

I think I may have answered my own question. When I did “Blind Solves” I didn’t put in the “Scale”. I thought “blind” meant “blind”. When I do put the scale into the scale box my images solve quickly.