FLI Kepler 4040 problem with new NUC10i7

I have been using SGP with an FLI Kepler KL4040 camera and it’s latest ASCOM Driver running in a 7th generation Intel NUC 7i7 mini computer. I recently built up a new machine using the latest NUC 10i7 computer. When using the new NUC, I’m getting a strange behavior which is after a first image is downloaded and moving on to a second image, the second through fourth image downloaded are just copies of the first image created. When the 5th image downloads, it is a new image. I found this after doing the software setup and trying to run autofocus. My focus curve was not moving at all until hitting th 5th download.

I’m running the exact same software on both machines.

I ran the FLI Pilot native camera capture software that comes with the camera and this doesn’t happen. I also tested Maxim DL with the ASCOM driver and Maxim plugin, and the problem does not repeat.

This leads me to believe that it is a problem with SGP and the ASCOM driver and it’s interaction with the new Intel NUC hardware.

Can anyone help me troubleshoot this further?

Jim Grubb

Just to be clear, it works fine on the older NUC 7i7 but not the newer NUC10i7.

We’ll need logs to look into the issue. Please see here:

Thank you,

Thanks Jared,

I didn’t know about the log files. I went and had a look at it myself and found the problem. The checkbox for “Use High Speed Download” was checked. Un-checking it solved the problem.

This camera is very picky about it’s usb connection, dosen’t like any hubs etc.

Thanks for the guidance.

On a side note, I’m using the AP 1100 mount with encoders and APCC. When using SGP and ASTAP, I’m able to run a 90 point model in under 30 minutes. This has allowed me to get 600 second unguided exposures that are spot on.

I’m trying to figure out how to dither if I don’t use PHD2. Is that possiblee?


Ok. I found this one as myself as well. I see that I can do it with Direct Camera Guide.