Help with auto flats

I tried the auto flats last weekend and all the flats exposure time were at 0 length. I’m sure I screwed something up in the set up. When I export the auto flats capture tool the exposure length is set at 0. when I fill out the auto flats scheduler then start the sequence I get an error message WARNING for after sequence auto flats run “this auto flats sequence does not have any incomplete events to capture”
continue anyhow?

A couple questions.

I saw a guide on setting up the auto flats but can not seem to find it anywhere. Did it go away or can someone point me in the right direction to see a detailed explanation on how to set up autoflats?

Do both the Auto flats capture tool (tools-auto flats (flat frame capture tool) and the auto flats scheduler (sequence-auto flats scheduler) have to be filled out?

Any help would be greatly appreciated.

1 Like

AutoFlats at the moment is “very beta”. You are certainly welcome to try it out… Problems like this may not be user error and, at theis stage, could indeed be genuine bugs. After release we will work on easier to digest guides, but for now, we can offer a complete set of documentation that, in its current state, is more like vomiting of information. You can find that here:

I’m not certain that I understand this question, but AutoFlats can be used:

  • as a standalone tool (like a mini-sequence)
  • as a scheduled part of regular sequences running before and/or after the sequence.
  • as a tool to export a set of flat events into a normal sequence (I’m not sure if this will make it into the final release… it’s not the intent of AutoFlats to do this and leaves so much of what AutoFlats does on the table)

Than you for the links, they are what i was looking for. I’ll see if i can make some headway with the help of the links.

I was just wondering if the auto flats capture tool ( I just noticed after posting it says “manual mode” or something like that at the top) worked in conjunction with the auto flats scheduler. But it appears they are separate entities. When i exported from the auto flats tool, the exposure length in the sequence was showing 0 seconds and it appears that SGP just treated it as a regular flats event. I Set it up to do sky flats so I’ll have to check the fits header and/or SGP logs to see if the telescope moved to the desired position.

I was testing with the auto flats scheduler, set it up for before and then after sequence starts and I get this error message when I click on “run sequence”

Warning for “Before Sequence” Auto Flats run: This Auto Flats Sequence does not have any incomplete events to capture!
Continue anyhow?

They are one and the same. AutoFlats can be run as a standlaone tool or you can ask the main sequence to run it before and/or after the sequence. Either way, it’s still AutoFlats that is capturing the data.

I’m not sure if this export function will be in the final release. It is really contrary to the notion of AutoFlats and by making the entry of a normal Flat event slightly easier it essentially throws away everything AutoFlats can offer you. It will probably go away. For now, I would focus on using AutoFlats without export.

This is likely because your profile does not have default exposure length set for those filter / bin combinations.

Are you saying there shouldn’t be an option to continue with no work to do? That seems right.

I understand the export function now and will continue testing the scheduler.

No. I’m saying I get that warning and when I hit continue anyhow, the sequence runs but auto flats does not.

I filled out the auto flats scheduler, created a new sequence with profile, selected the profile, created a target and set up 2 light events. Then when I click on run sequence I get that warning.
I’m not sure what it means or how to correct it to get auto flats to run.

In the schedulaer have you seen the “preview” function at the bottom of the window? It will allow you to see what AutoFlats, based on the current scheduler settings, will capture. What may be happening and something I need to provide warnings about is that “sync progress with disk” is enabled by default so if you have any flat frames in the output folder that meet the requirements of the frames that AutoFlats wants to capture, then those frames will be counted toward the total completion progress and it’s possible, if there enough of them, that the AutoFlats run thinks it has no work to complete.

Yes I saw the link but it was not working for me. However I was able to open the preview from the top menu “sequence -Preview before auto flats run”. There were a number of items in there and they had the check mark making the active.

The “sync folder” was activated but the flats folder, as well as my lights folders were empty before starting the sequence. I’ll try unchecking the sync folder.