Help with autofocus step size calculation

Hi - I have read the help file on this but not sure if I have it right

i used the wilmslow astro calculator to calc the CFZ as 92 microns. I have a microtouch autofocuser and info from the Starizona team tells me that 1 step = 0.6 microns of primary mirror movement in my SCT. So I divided 92 by 0.6 to get roughly 153. Is 153 the number i put into sgp as the step size?

thanks for help,


Hi Paul,
Don’t worry about all the math. If I were you I would start with a step size of 100. What you want to see is a “V” curve on the autofocus graph where the two outside points (out of focus) result in a HFR of 3-4x the bottom point of the “V”. For example, let’s say your best focus is an HFR of 1. Aim to have the two outside points between 3 and 4 HFR.

If you have a bahtinov mask, focus with the mask first so you know you are close to focus. Then run autofocus and if the first autofocus point only gives you say 2 HFR, then increase the step size. If the first autofocus point gives you a 6 HFR, decrease the step size.

I hope that’s clear :smile:

What Joel said, the step size is more important in programs like Focusmax… With PHD you just want to cover your focus range from an HFR 3-4 on each side of the focus. If you do that, you’ll get it.

Thanks very much for your help, much appreciated. I tried it last night (1st clear night for weeks…) and unfortunately could not make progress. Here’s what I did:

Used nebulosity (Craig Stark s/w) and did a fine focus so I knew focus was pretty good. Noted the focus position on my microtouch focuser (30174)
In sgp:
10 second exposures, asked for 13 points, step size 100. Ran autofocus and it produced a scattergram of points. Resulting focus point wasn’t focused…

Without going into all the detail, I tried various things with step sizes of 10, 20, 40, 150, 200 all with more or less the same result.

Also tried starting slightly out of focus, but that was unsuccessful too.

So a bit stuck really, just focusing using nebulosity fine focus tool at present.

Any further help greatly appreciated.

My scope is a Celestron c11 at f6.3. The focuser is a feathertouch with microtouch attached for control. Using the buttons on the controller, I can move in and out of focus from both directions, so I know the focuser is working. Also from within sgp control panel I can press the software coarse/ fine in out buttons and the focuser works.

One thought I have, is, perhaps the SCT mirror is not settling enough between exposures in order for the autofocus routine to acquire good quality star images for its calculations?

I have this vision of the next exposure being started before the mirror has settled. Having said that, it is a minute movement, so I am probably clutching at straws.

thanks again,

Just also to say I did a goto a star cluster before I did all the above, near m31 area, so there were plenty of good stars.



Is your stepper attached directly to the mirror or do you have a crayford on the back of it? My guess is you’re not overcoming your backlash and you need to figure that out before you can run autofocus too. It should be fairly consistent.

I would echo what mads said, and also say that I think 13 data points is probably too many. Depending on your step size, 13 data points may move the focuser too far out of focus for the AF routine to accurately measure. When the first data point comes in, do the stars look slightly defocused or are they donuts?

Can you possibly post a log file with the autofocus run, along with a timestamp hint for when the AF run took place?


Another thing I noticed when I use the autofocus is that for refractors, I use a 2x2 binning and get good consistent results. However, with my SCT, I’m running at an image scale of about 1/3 arcsecond/pixel and the 2x2 doesn’t cut it. I’m all over the place even though I have backlash handled (in my case I have an Optec TCF). Step size changes really did not do the job. When I went to 4x4 binning, auto focus improved dramatically. It helped to keep the stars from developing donuts when near the edges of the auto focus runs when you have the step size set to the approximately 3x size of best focus. Now I get nice V/U curves and focus has improved.

Frank Z…

many thanks for this, it is a feathertouch microfocuser with starizona’s microtouch attached (no crayford, just a replacement for the standard sct focus knob). I will check with Dean at Starizona as to whether there will be backlash. Good point, thanks. It’s raining for few days now, so will be a while before I get back

1 Like

thanks for all the replies - much appreciated. i will try binning, checking for donuts at first focus point and reducing to 9 data points. If I can’t progress, i’ll post a log file too

best wishes all

1 Like

hello again

I have adjusted the settings and had some success, what works best but not consistently is 11 points with a step size of 85. I have tried also reducing the points to 5 and increasing the step size pro rata so that the extremes remain at approx 3 to 4 times hfr minimum.

Unfortunately my 1st outer point consistently reports a HFR lower than the 2nd, so this 1st point is never a good contribution. I often end up with red coloured lines but very infrequently green ones. I haven’t looked yet what red and green means but i guess it will be obvious… so five data points with one bad one is no good, that’s why i decided on a larger number of points so the 1st one doesn’t have such a great effect on the resulting curve. I have also noticed that my curve is always 'skewed to the right - i.e. most of the points appear on the right. If I choose 7 points, typically 5 will be on the right, so my curves are always asymmetric.

Anyway, I think i need to reverse my approach, so the SCT mirror moves to 1st point against gravity. So I checked the box in control panel focus tab which allows focuser direction to reverse. I think I may have found a bug (in either sgp or Starizona’s firmware I’m not sure). If I check the reverse box and try to run autofocus, nothing happens when the graph axes appear. If I cancel and use the ‘in’ or ‘out’ software buttons in the control panel, the focuser just keeps repeating that step for ever. I did not go outside to check f this is physically happening, but there is no way back in SGP, only close and reload SGP.

sorry for such a long and problematic post, I’ll keep trying and any observations/ help much appreciated. It’s really nice when a good curve appears, but I only got it twice in about 20 attempts!


also just to say i took Frank’s advice and am binning at 3x3, so no donuts at 3-4 HFR outer points.

How do I retrieve a log file please? Perhaps that might help me identify and analyse the problem