Integration does not start

I set up a new sequence for a different scope and mount. When I start the sequence it says “filter set” but hangs up there; integration does not start.

Sometimes it says “running sequence” but hangs; then it says “sequence aborted”.

This apparently has something to do with connecting with the QHY247C, however the frame and focus as well as autocentering images download and work, but the program does not start the camera in the sequence. I am using 3.1. Same with version 4 32 bit.

Peter Bresler

It’s hard to troubleshoot with descriptions alone. Please recreate the issue and send us logs so we can take a look.

How do I attach the log files?

Please see the link I attached in the reply

I am not finding a link. It would be a lot easier just to attach the file(s). Can you send me a conventional email to which I could respond?


It seems as though SGPro has a bad bit of feedback for this issue. Your sequence has requested that SGPro automatically adjust the focus position by some value whenever a filter change occurs and, unfortunately, this value is missing. SGPro doesn’t actually freeze, but it will take a while to realize it can’t proceed. I have fixed this issue in SGPro 4 and it will no longer allow a sequence to start in this state. For you, I think you’ll be fine if you correct the issue by either disabling the setting to auto adjust the focuser for filters or by entering the focus point data for your filter set.

To disable the setting:

Or enter the focus point data here:

Thanks,. Easy fix, just needs an error message. I will just select no focuser.


I now would like to do auto focus with the Septo Senso focuser. The driver shows and I select it, I set the autofocus settings in SGP. (The focus controller works outside of SGP.) When I start auto focus the correct number of data points is not displayed, and again, SGP hangs up.

I was able run sequences when I selected “no focuser”.

Peter Bresler

Please use the SGPro issue reporting tool to send logs. The link you provided is not valid.

I tried the reporting tool. Here is the logs link again.

Just FYI Ken, I tried to use the error reporting tool recently and it failed for some reason. This was on beta 725, but I think I remember that happening before as well. I tried to post to the private support instead of the public support if that makes any difference. Just something to look in to.

Hmm. It looks like maybe your SGPro and forum accounts are not linked? Did you link them? Wondering if that is broken for mods…

Yes, it looks like the SGPro and forum accounts are not linked. I can only log in to the forum with Google, but log in to SGPro with different credentials.
Somehow I wasn’t aware that these accounts should be linked.

I wish it weren’t true, but the existence of the forum before the existence of the new website means that users can have diverging user names between the two systems. New users don’t require the link… their usernames will match.

I am still trying to get the Senso Septo focuser to work with SGP. Here is the ASCOM log during an attempt at running autofocus with it.