Licenses do not match current machine error


I have started to get this issue where one of my machine is unable to hold on to the SGP license and i get the following error show up in the log file “Licenses dot no match current machine!” and the SGP pro version reverts to SGP Lite.

I have tried uninstalling and reinstalling the product. I have also tried removing the license via license manager and I can see the license get allocated again, but the next restart of SGP requires license information once again.

Unable to attach the log file so here is a snippet:

[09/12/20 21:37:44.714][DEBUG][Unknown][NONE] .NET Framework Version: 4.8
[09/12/20 21:37:45.727][DEBUG][Main Thread][NONE] Licensing: Machine ID found…
[09/12/20 21:37:45.727][DEBUG][Main Thread][NONE] Checking for valid internet connection…
[09/12/20 21:37:46.171][DEBUG][Main Thread][NONE] Valid internet connection detected…
[09/12/20 21:37:48.647][DEBUG][Main Thread][NONE] Licensing: Request for licenses successful, writing cookie…
[09/12/20 21:37:48.650][DEBUG][Main Thread][NONE] Licensing: Applying licenses…
[09/12/20 21:37:48.651][DEBUG][Main Thread][NONE] Licensing error: Licenses do not match current machine!
[09/12/20 21:37:48.655][DEBUG][Main Thread][NONE] Licensing: Licenses applied…
[09/12/20 21:37:48.655][DEBUG][Main Thread][NONE] SGLite free license…

Can you kindly assist? Thanks

What version of SGP are you using?


Hi Jared,

Thank you for coming back to me so quickly.

I am currently using the latest v (installed on laptop) but shows on the license management (web).


Hi Jared,

Is there anything else you need from me to get to the bottom of this issue and help me resolve this?

Thanks in advance.

Hi Devs,

Any help please?

Thanks in advance.

@angryowl We haven’t ever seen this one before and I am uncertain why this would happen. Are you using a virtual machine or anything like that? What is the name of the machine observing this issue?

Hi Ken,

Thank you for your message.

It is not a virtual machine but a Windows 10 on a physical laptop. The name of the machine is Astro-Pc.

Many thanks in advance.

Kind Regards,

Can you request a trial extension via the Help menu? This will temporarily allow you to use the machine while we look, and if there is trouble granting a trial extension it will provide information as to what is happening

Thank you once again for the swift response Ken.

I already have the same license applied to another machine which works fine but only one that it does not.

When I look at the “License Information”, it has zero days left for the trial. How will this affect my other machine?

Trials are machine specific, not user bound. Can you please request a trial extension on Astro_pc?

Ok will do sir.

While I was waiting for the response, I did however find a similar thread which could possibly give us a hint

I did purchase this laptop from a friend of the astro community and he was using SGP, could it be just that?

Actually, your machine ID made it into the database twice. I think I have cleared the issue. Can you reattempt license registration?

1 Like

Thank you Ken.

Let me try this and I’ll get back to you within 5 min. Just need to fire up the laptop.

Thank you for the assistance so far.

Hi Ken,

That worked a treat.

Thank you so much for sorting this out so quickly.

Much appreciated.

Kind Regards,

1 Like