Main Window Lockup on V

Last night, SGP worked fine until I attempted to terminate the program. SGP had detected a filterwheel malfunction and eventually aborted, closed the dome, and parked the mount. All good, as I suspected the wheel might fail because I’ve been having trouble with it. When I got up, I tried to close all devices in the main window Tools but could not access anything in the window. The other windows (sequence and equipment) were active so I closed the devices there. I had to end the main window task with Task Manager.

Not a big deal, I suppose, as nothing was lost. Just disconcerting. As an aside, lots of crazy temperatures reported as I have been unable to calibrate Robofocus external to SGP. Just FYI.

Logs at:


Thanks for the report. Unresponsive UI can be difficult to correlate with log events. In the attached log, I see activity all the way through 05:36. If you have a moment…

Do you have an approximate time here? I assume the forced termination of SGPro was shortly after this time too?

As an aside, if it makes your life any easier, SGPro has a built in log sharing tool that will allow you to pick from any of the logs for past SGPro sessions and automatically share them with us. Certainly the manual method you have used here is just fine too.


Hi Ken,

Thanks for replying. I know you’re rally busy.

I think it’s related to the unresponsive filter wheel. I just ran a test that doesn’t exactly simulate the problem since I’m not running sequence but nonetheless shows a possibly correctable issue. I tried to simulate the unresponsive filter wheel by turning Nautilus off and on until it worked (it was failing for quite some time) then connected it in SGP then turned it off and on while connected to get it to fail. It did fail (I can tell by listening to it, as the failure mode is runaway rotation). While it was failing, I tried to set to the red filter. As you can see it says moving; it never timed out. The main window was not locked in this case and I was able to close it. Shouldn’t SGP have a timeout to catch that issue? Log is at:


Did you mean to attach a log link?

Hi Ken,

I sent you a very short reply with the link, but I got this:

"We’re sorry, but your email message to [“”] (titled Re: [Main Sequence Software] Main Window Lockup on V didn’t work.

To promote more in depth conversations, very short replies are not allowed. Can you please reply with at least 10 characters? Alternatively, you can like a post via email by replying with “+1”."

The link was actually in the other message just before the screen dump image. Here it is again:

I hope this message is long enough. Regards, Kent

No, sorry, that didn’t work. The forum does not allow direct attachments of files… just links to them hosted on other places.