Marquee Drawn In Wrong Spot

When I try to select a new focus area, SEQ draws the marquee up and to the left of the cursor by a considerable amount so it is very difficult to know where the box will be.

What feature is this in reference to? The framing and mosaic wizard?


Frame and focus/ Use sub frame (drawing the sub frame) Sorry for not being more precise.

Ok I’ve got a photo of what is happening (this is from the 2.4 beta):

This is happening during sub frame selection of frame and focus. What you see here is I have dragged out a selection but have not released the mouse button. Note that the selection marque (dotted box) is being drawn up and left of the cursor. The cursor and the lower right corner of this box should be at the same place. Once I release the mouse button the actual sub frame selection will be aligned to the final cursor position. So the selection preview marque is being drawn up and left to the actual final selection. This makes it really hard to do an accurate selection

Thanks. What does the rest of SGPro look like when this is happening? Is it maximized? Custom? How is the image window docked when you are doing this?

I tried the main window max and smaller. I tried with the image window docked to the left (no other docked windows). I tried with the image window docked to the right of other docked windows as well as docked in the center, I tried the image window docked top and bottom.

All show the problem.

I cannot seem to duplicate this.
I’ve tried different binning, different zoom levels, different rotations, different aspect ratios, docked, undocked, and pretty much everything else I could think of to try and make this happen. The worst that I can do is get it to lag a little when I remote into my observatory machine.

Where did the marque start in your screen shot? Was it drawn where you clicked or was this also offset?


It was offset from start to end. It seems to be a constant offset no matter where drawn. In case it makes a difference this is Windows 8.1. Perhaps you can create a test version that will gather some debug data that I can run for you?

We can try that. Although I’m not 100% sure what debugging info would be helpful but maybe the click and drag locations may help to narrow things down.

If you right click does the context menu show up correctly?

All development happens on 8.1. We test on 8.1 and 7 so I don’t believe this is a 8.1 issue. It would be nice to hear if others are seeing this issue as well.


The right click context menu is working.

This is an old report which has been on the back burner, however, I have some new data. I just started a trial for the Framing & Mosaic Wizard and when I try to “Draw the target rectangle” I get the same result as reported previously for Frame and Focus. That is, the dotted line preview marquee is being drawn offset up and to the left of the actual cursor position. Like before, the final box position matches the cursor but the dotted line preview box is offset. Perhaps with this new aspect of the problem you can come up with some way for me to capture some debug data for you.

Hopefully I’m not confusing issues, but I believe that we have this narrowed down OS level font scaling. Those that operate at 100% do not seem to experience this issue.

It has been determined that font scaling is related to this issue. On my machine, with font scaling set to “Recommend” it fails. If set to one step smaller than Recommended, it fixes the problem, however, I’m left with small hard to read fonts in the rest of SGP. Any chance this can be fixed?

Yes, of course. It’s on our backlog… just has not been prioritized.

I went to check how difficult this would be so we would be able to prioritize it. Unfortunately, I am not able to reproduce it. I changed scale to 125% and 150% and everything was drawn exactly where it should be. To be clear, is this the Windows setting you are adjusting?

Using Windows 8.1; Right click on screen; click on “Make text and other items larger or smaller”; then there is a horizontal slider that has three possible positions. The center position is the “Recommended” setting. The left position (smaller fonts) is the one that cures the problem.

Ok, following your method I was able to reproduce the issue you are seeing. I don’t know how to fix it immediately, but I think that you can prevent this issue from showing up AND also have the bigger font you prefer.

Instead of using the slider, check the “Let me choose one of the scaling levels for my display”, then choose 125% or 150%. SGPro seems to work fine when Windows is scaled in this manner.

We’ll certainly look into at some point, but it probably won’t be prioritized immediately.

On my machine I don’t have 200%; 125% fixes the problem; 150% does not fix it. And weirdly, Windows 8 now seems to be stuck on 150%. I can’t seem to change it back to 125%.

I found that when the scaling is set to 125% SGP complains when it starts that scaling is not 100%, however, as noted 125% is what works. I figured out the problem of not being able to reset from150%. At 150% the apply button was off the window so one has to scroll to find it.

Yes, we try to do our best here, but SGPro is not designed for it. That said, it is just a one time warning.