Merdian Flip failed to flip


I read through the various posts on Meridian flips failing and I was hoping you can help. It worked the previous night and I can’t think of any changes other than the target. The Meridian flip should have occurred from 11:30 to 12:30, I set up the mount to go 30 minutes past and flip. Even with imaging I can do at least 2 hours so 30 minutes is good. Link to log is here:

Link to sequence is here

What did I do wrong?

What are your settings for the meridian flip? Did you turn on ‘wait for flip’? My guess is you ended up in a scenario where it couldn’t make it, tried to flip afterwards, and hit a limit.

I can’t view logs right now though.

The settings are as follows:Minutes past the Meridian to Flip: 30Wait for Meridian (unchecked)Pause before Meridian Flip (unchecked)Auto Center After Meridian Flip (Checked)Pause Before/Pause After (unchecked)

Try wait for meridian. I’d recommend giving it a try during the day. The whole purpose of ‘wait for meridian’ was to avoid these situations. If you’re going to push your imaging right up to the limits of your mount, you have to give it a buffer to do the flip otherwise it’ll get stuck.


The log file you provided starts at 3:51am. Do you still have the log that shows the issue?

Hi Ken
Sorry copied the wrong link, as you can see the record stops at 10:18 and restarts at 1:21 AM the next day.

| | |


| |
Shared with Dropbox | |




Well… the good news is that this issues has nothing to do with meridian flips… SGPro never even attempted one. The bad news is this:

  • Your camera ate it during readout of an AF frame
  • You have identified that SGPro does not protect against a timeout specific to readout

I am not sure how well SGPro can protect against this either. I added a little bit of code to do what we can, but I suspect that we called into the SBIG driver and it did not respond with anything (and blocked the sequence) for 5 hours until we get this:

[9/26/2016 3:25:00 AM] [DEBUG] [Camera Thread] SBIG Error while downloading image: RX_TIMEOUT

As for the error itself:

  • Make sure your SBIG drivers are up to date.
  • Make sure power to the camera is stable
  • Make sure you are using a known good, appropriate USB cable
  • If you are using a USB hub, make sure it is powered


I downloaded the new drivers they were not up to date.
I was using 120 so shouldn’t be an issue.
I have a new USB cable so hopefully that solves the issue.
I am not using a hub.

As protecting against this again, any way you can put in a 5-10 minute time out? for example no reply from a source stop the sequence?

Thanks for your help.

A watchdog timer would be awesome.

Glad you got it sorted.

It’s still happening but I think I know how the time out happens. It’s either changing the cooler temperature or selecting the settings. When I select camera settings I get the time out error right after that. I’m going to bed but I’ll take screen shots showing how I can cause the time out error, but looking through the threads I may have the drivers for an st pro??? I’m going to reload without st and see what happens.

Hi All,

I had technical support from SBIG review my process and also install all the new drivers and he discussed with the other developer and they state that SGP is trying to open the SBIG driver when its already open. SBIG believes it is a bug on SGP. He shadowed me while I recreated the error.

These are steps:

  1. Connect to SBIG camera
  2. Go to Frame and Focus > Press Take one
  3. After Photo Downloads, go to Camera Icon (cheontrol panel on SGP)
  4. On Camera Tab press the Settings Button
  5. Close the Settings Button (press OK)
  6. Go to Frame and Focus > Press Take one
  7. Get the following error message "SBIG ERROR WHILE ENDING EXPOSURE: DRIVER_NOT_OPEN

That’s weird. What camera are you using? I have an STF8300M and it doesn’t have any issues. I use frame and focus all the time. I updated my drivers about a week ago.

I have the Stf 8300-C

That is really strange. I wonder what yours is doing differently from mine. Like you said, you’ve tried the obvious… different USB ports, different cables, etc…

I wonder if my camera is, for whatever reason, handling it differently.

If you shadow me I can recreate it at will. I had the SBIG tech guy shadow me, he read the log and after reviewing the log, he stated SGP sent a command to open the driver for the SBIG camera when it was already open.

What version are you running? I haven’t updated… I’m still on 2.5.16.

Don’t know if this will help, but yesterday I hooked up a second camera (sbig) to a piggy backed FSQ. I was getting similar messages to what you are seeing and found this post which may help: Connect/configure SBIG STT-8300M/FW8G-STT Filter Wheel - Equipment Compatibility - Main Sequence Software.

1 Like

I’m on that was version that was available as a download.

Hi Gunny

Thanks but its a different issue :frowning: