Meridian Flip Fails with CEM60

Nearing the end of my trial period with SGP and have encountered a show-stopping issue. SGP is unable to perform a meridian flip. I’ve tried over multiple nights across multiple targets and sequences and get the same error every time.

“ASCOM Telescope: Failed to flip because starting pier side and ending pier side are the same!”

All other functions appear to be working correctly; slew, centering, plate solving, etc.

Using SGP
CEM60 has current version of Commander and all firmware is up-to-date (commander 5.63)

Snippet from the log file is as follows;
[10/15/18 20:52:18.308][DEBUG] [Pier Flip Thread] Meridian Flip: Sending Telescope command to execute meridian flip
[10/15/18 20:52:18.317][DEBUG] [Telescope Thread] ASCOM Telescope: Pier side is West
[10/15/18 20:52:18.318][DEBUG] [Telescope Thread] ASCOM Telescope: attempting pier flip using slew
[10/15/18 20:52:18.320][DEBUG] [Telescope Thread] Telescope: Slewing to J2000 RA: 21.0303171689049 (21h01m49.14s) Dec: 68.1593929561072 (68°09’33.81")
[10/15/18 20:52:18.320][DEBUG] [Telescope Thread] Telescope: Slew received J2000 coordinates, mount requires JNOW, converting…
[10/15/18 20:52:18.320][DEBUG] [Telescope Thread] Telescope: Slewing to JNOW RA: 21.0345555555556 Dec: 68.2390083333333
[10/15/18 20:52:20.776][DEBUG] [Telescope Thread] Scope reports it is done with synchronous slew, verifying…
[10/15/18 20:52:20.776][DEBUG] [Telescope Thread] Telescope: Slewing has completed
[10/15/18 20:52:20.776][DEBUG] [Telescope Thread] Telescope: Settling for 2 seconds
[10/15/18 20:52:22.776][DEBUG] [Telescope Thread] Telescope: Settling has completed
[10/15/18 20:52:23.276][DEBUG] [Telescope Thread] ASCOM Telescope: Failed to flip because starting pier side and ending pier side are the same!
[10/15/18 20:52:23.488][DEBUG] [Pier Flip Thread] Meridian Flip: Telescope command to meridian flip has completed
[10/15/18 20:52:23.488][DEBUG] [Pier Flip Thread] Meridian Flip: Telescope failed to perform meridian flip
[10/15/18 20:52:28.471][DEBUG] [Pier Flip Thread] Meridian Flip: Procedure complete

The CEM60 is correctly reporting the side of the pier in Commander.
The CEM60 coordinates match between Commander and SGP.
The CEM60, SGP and the PC all have the same date and time (within a few seconds)
I can manually execute a meridian flip within SGP perfectly fine.

I’ve tried setting the meridian flip within Commander to be at 0, 2, & 4 degrees past the meridian with the same resulting error.

Regardless of the setting within CEM60/Commander, SGP executes the flip precisely at the meridian. It doesn’t wait until 2, or 4 degrees past the meridian.

I’ve attached the complete log file and images from the equipment configuration.

sg_logfile_20181015204427.txt (111.5 KB)

Any help would be greatly appreciated!

Hi Ricowley,

I’m not good at reading logs, so what I have may not be relevant.
Also, mine is a CEM120, so not apples to apples.

Anyway I set iOptron to STOP at 5 degrees past meridian. And SGPro to FLIP at 1.25 degrees (i.e. 5 minutes time) past meridian.

Mine works a treat.

Hope this helps,

The settings I have my CEM60 work for me. Set SG to wait 1 or 2 degrees past the meridian before doing the flip.0 does not work. Then change the settings in the mount handbook to stop a few minutes later than your setting in SG. Only SG should perform the flip. That works for my mount. Hope this helps.

Your settings in SGP are telling SGP to flip exactly at the meridian. SGP does not know about the settings inside of commander…we can’t read those. If you want SGP to flip a little past the meridian you’ll need to set the “Minutes Past Meridian to Flip” to some non-zero value.

As others have mentioned it’s always safer to flip a smidge past the meridian. SGP should be getting the sidereal time from the mount. So SGP should be using the same criteria as the mount to determine the meridian. It could be an issue with JNow to J2000 conversion.


Thanks all for the suggestions. I will try the above suggested settings tonight and report back.

I’m happy to report back SUCCESS! However, the issue was not the timing of the flip as described above.

I continued to have a failed meridian flip after I changed the meridian flip on SGP to occur 2 minutes past the meridian and instructed the CEM60 to flip at 10 degrees past the meridian. As I understand, the idea is for SGP to execute the meridian flip and NOT the CEM60. The meridian flip failed and returned the same error: ASCOM Telescope: Failed to flip because starting pier side and ending pier side are the same!

On a hunch, I installed the ASCOM mount driver for the CEM60 from the ASCOM website. I had previously used the ASCOM mount driver from iOptrons website. I remember reading that the drivers available on the ASCOM website had passed “driver conformance test”.

After installing the driver, the mount repeatably performed an automatic meridian flip. I’m not sure how to identify the exact driver version, because the download files do not appear to include any revision number.

In summary, make sure you use the ASCOM drivers that are provided from the ASCOM website and NOT iOptron’s website.

Thanks all!