Mosaic centering will fail after meridian flip

I do not know… we have only tested against “m”. There is a very good chance that it should.

thanks Ken,

Seems to be working fine …UNTIL …after Meridian Flip or crossing the Meridian, than it seems to move the scope in the opposite direction of what is needed for centering. I noticed this error message…

5/2016 3:38:24 AM] [DEBUG] [Telescope Thread] Telescope: Slewing to J2000 RA: 14.0538888888889 Dec: 54.3533333333333
[3/5/2016 3:38:24 AM] [DEBUG] [Telescope Thread] Telescope: Slew received J2000 coordinates, mount requires JNOW, converting…
[3/5/2016 3:38:24 AM] [DEBUG] [Telescope Thread] Telescope: Slewing to JNOW RA: 14.0636094286631 Dec: 54.2729727320343
[3/5/2016 3:38:24 AM] [DEBUG] [CP Update Thread] Error in control panel UI updater: Object reference not set to an instance of an object.
[3/5/2016 3:38:51 AM] [DEBUG] [Main Thread] PopulateDataModel: Transferring view to the data model…
[3/5/2016 3:38:51 AM] [DEBUG] [MF Update Thread] Performing serialize…

Full Log:

I don’t think this is a meaningful error… just a UI update error (it might be relevant… logs would show if they are or not. The link you provided is broken).



Just to let you know . Centering is working perfectly . I am using 1.28S eqmod. So it looks like anything from at least M will work. Thanks for the help !!!


Hi Ken,

Well , it was working great for a while. Now it is back to not centering after the Flip. So I went into the eqmod driver setup and noticed that there were data points , I cleared those and the centering after the flip worked just fine. :confused:

So my question is : Do I have to make sure there are NO data points every time I connect to the eqmod driver ?? How often should I clear data points during the night ?? They look like they are added automatically as SGP does its magic.

thanks again,

If EQMOD is seeming creating alignment points that would imply tha tit has either been left in “Append on Sync” mode and hasn’t been set to “Dialog Mode” (as shown in Ken’s EQMOD tutorial), or perhaps you have it configured to load up a previously saved alignment model on unpark?


thanks Chris…I will triple check the settings tonight … :confounded:

Hi Chris,

Last night I noticed that the DxSA and SB windows were showing data being added but the Point Count was ZERO so just before Flip time I deleted those data points and all went well with SGP centering the target.

I triple checked my settings before I started last night and everything was done according to SGP requirements but there was left over data from the night before showing in only the DxSA and SB windows so I don’t understand why data points were being added and saved to those windows.

Do you think I am still set up wrong , is the driver window suppose to show data points being added, should I try using Proximity Range . I have a portable setup so I start from scratch each night out. I should mention that I am using a Bluetooth connection to the mount and pulseguiding…is this messing up SGP ??

Thanks Again !!

I had this problem and it went away when I used the suggested SGP settings. Clear your points to 0, Clear out DxSa and SB. Make sure your User Interface is set to “Dialog Based” and Alignment Behavior is “Nearest Point”. It should now work without you having to keep clearing points.

thanks Tim , I am like 99.9999% sure that is what I have already done. BUT, I will check again…I am wondering if I have a previously saved model from a long time ago loading without me knowing. :confounded:

Hi Dennis
The DxSa and DxSb are offsets set every time you sync. They are not data points, they offset the whole model. These numbers basically represent the error in setting the mount ‘home’ position when you set up.

***EQMOD will not accept a sync when the scope is past the meridian, and zeroes any existing DxSa/Sb values. Depending on the DxSa/Sb values before the sync, this can cause EQMOD to sync back across the meridian so when SGP issues a slew command EQMOD thinks it doesn’t have to flip.

The solution is to calibrate the original mount position as close as possible, and after the first sync check that the number of DxSa/Sb steps is smaller than the ‘Degrees Past the Meridian’ value in the SGP flip settings (based on steps/degree for your mount).


This was the case for EQMOD versions prior to V1.28n, however from V1.28n onwards EQMOD will simply reject the sync by raising an exception (which at the time SGP was also modified to catch) whilst leaving the DxSa/Sb (sync offset) values unchanged.


That is easy to check. If your point count is showing as 0 then you have no model loaded.


Paul and Chris,

I just ain’t getting it. Last night, eqmod was showing sync data in both DxSa and Sb AFTER I cleared the data and fired up SGP and did a solve and sync so the scope would know where it was. BEFORE the flip, everything worked just fine. AFTER the Flip it would NOT center on target until I cleared the data that was showing. As soon as I cleared the data it centered perfectly.

So what is the bottom line ?? Is it doing what it is suppose to do or am I doing something wrong ?? I was under the impression that if I followed the SGP instructions when using eqmod everything would work just fine after a flip …

Totally Confused Now,


p.s. I am absolutely sure my settings are correct, according to the SGP eqmod instructions.

Hi Chris,

thanks for the info …I will keep messing with it, I was NOT letting it track very far past the meridian …maybe THAT is the problem .


If they are not data points (DxSa/Sb) then why does the scope suddenly center fine as soon as I delete those points ? The points just seem to stop the centering process from working properly.

Still Confused,


Hi Ken and or Jared,

Everything was fine till right after the Meridian Flip , she just would not center and apparently got stuck in some kind of loop . I stopped the centering , which parked the scope, had to unpark and slew to target and within two tries it centered just fine.

Starts around 1:30am …I think…

Not really sure. We kept syncing and telling the scope to slew and it just never made it there. Could be some backlash or the mount is west heavy and keeps rocking back after the slew. You could always up the error amount if that is acceptable. Seems like you were only a couple of pixels away.


Understood, but if that is true …how come if I slew from a parked position , the centering works just fine ?? It is always
after a meridian flip that the problem happens. :confused:

Well after a meridian flip 1 thing is always certain. Your scope is on the east side of the mount. So if it is a balance/backlash issue then it would be in the same position each time.

If you setup a target that is just slightly west of the meridian and start that from park do you still have the same issue?