Mount Keeps Disconnecting

I have a recent Windows 11 laptop with SGPro and other imaging SW loaded and can get everything connected and working but the mount (an AP mount using AP GTO V2 ASCOM driver) randomly disconnects and all my software such as SGPro, PHD2, etc. lock up. Link below is a log from SGPro.

LOG File

I’ve not yet enabled the ASCOM logger but may try that tonight. I had one night a few weeks ago when everything worked great after I switched the USB cable from my hub to the laptop to another port on the laptop and didn’t see disconnects all night. But the last couple of nights I can’t seem to get it stable. May not be SGPro but thought I’d start here. I had all the same set up working pretty well on an older Windows 10 laptop that wore out and feel I’m very close to everything working on the new one.

Thoughts appreciated.

Make sure that under “Device Manager”, “Universal Serial Bus Controllers”, that under the properties for each device, “Power Management” each of the boxes are unchecked.

I think that you may have attached incorrect logs. Also, as a note, SGPro makes log submission easy and it can be accomplished in app. See here for guidance:

I’ll try that tonight. Thanks for the suggestion. I did try bypassing the USB hub from my mount and plugged the mount USB cable (really a serial to USB adapter) directly into the other USB port of the laptop and everything worked. So the issue appears to be a communications conflict through the USB hub.

Thanks Ken. I’ll try that. The problem does seem to be with a communications issue getting through the USB hub.

Steve, I’ve been having similar issues (new Windows 11 laptop, AP mount) and keep getting COMM errors in APCC and lost connections with the mount. I assumed it was a bad cable but replaced everything between the laptop and control box. I can also connect with everything but at some point during the night will get the errors (usually a “No response from mount”). I hope you were able to solve the problem. I’m going to zip my logs and send to AP for help.

That’s interesting John. So far, the only thing that has been working is to bypass my USB hub between the mount and my laptop which is not ideal. Do all your other connections stay solid? I have an AP 900GTO with ATEN serial to USB adapter and a USB extention cable going to the laptop.

I had similar problems with cheaper USB hubs, powered or not. In the end I bit the bullet and bought a 4-Port USB 3.0 Hub - Industrial USB Expansion Hub and that cured all my issues: camera, mount, guide cam, focuser coonect OK. I also use a 10m USB3 active cable to connect to a desktop but shorter cables connct OK to a laptop adjacent to the scope.

I have a semi-permanent setup. We live in a rural area and our place is gated so I keep the rig outside and control it from my laptop inside the house. It’s a bit far for a USB cable so I have an Icron Ranger 2304 (basically, it’s a keen little device – you plug the Icron’s sending unit into a USB port on the laptop and it connects with a receiving unit at the mount via a 100 foot ethernet cable. Then I run a short USB cable from the receiving unit to the CP4’s USB port). It’s basically just a USB over ethernet device. However, recently, there have been issues with the use of virtual ports with APCC (not sure if you use the APCC software). The folks at AP came up with a fix but I’ve had to resort to connecting to the ethernet port on the CP4 by plugging in a USB to ethernet adapter to the Icron receiving unit and then connecting to the ethernet port on the CP4. It’s a little Frankensteinish but I haven’t been able to get it work otherwise. I’ve bought a new Icron Ranger, new USB cables, new ethernet cable, and checked and re-checked all connections. I zipped my log files on APCC and sent to AP this morning. It’s the darnedest thing. I can open up APCC and easily connect to the mount and control it via APCC. I can easily connect to the mount via SGP. However, at seemingly random times during an imaging run, the sequence will abort and say I’ve lost connection to the mount. I have to disconnect everything and then reconnect. It will reconnect perfectly fine. I can then run the sequence again but, at some point, the same thing will happen. I’ve gone several hours without it happening. Then, on another night, I’ll only go several minutes. I’ll let you know what I hear from AP. I’m now a little skeptical that it’s anything to do with my connections (other than perhaps at the CP4 itself) as I also run my camera, guide camera and focuser via the Icron Ranger connection and all work flawlessly.

Interesting setup John. I have CP3 with a serial port only and no APCC. Just use the AP ASCOM interface. It is a real discovery process to find out what works for a given setup.