Nikon DSLR


after the API with DSLR should be OK, I tried to test with my Nikon. I don’t get the Cam working with SGPro itself. Below the Log File part. When i’m using Nikon Camera Control Pro 2 instead on the same Laptop, the Camera works fine. I have no DSUSB device attached (because I don’t have one).
Camera could be selected, I can start the Exposure (Cam is going to PC mode), no exposure made by the cam, SGPro is hanging in a loop ‘downloading’ in the status screen.

Any idea ?


[11.12.2016 18:44:38] [DEBUG] [Camera Thread] Nikon: DSUSB device NOT found
[11.12.2016 18:44:43] [DEBUG] [Camera Thread] SGM_CAMERA_CONNECT complete…
[11.12.2016 18:44:54] [DEBUG] [Camera Thread] SGM_FRAME_AND_FOCUS message received…
[11.12.2016 18:44:54] [DEBUG] [Camera Thread] Nikon camera: frame and focus…
[11.12.2016 18:44:54] [DEBUG] [Camera Thread] Setting sensitivity
[11.12.2016 18:44:55] [DEBUG] [Camera Thread] Nikon: Setting output to RAW
[11.12.2016 18:44:55] [DEBUG] [Camera Thread] Nikon: Expousre using native shutter speed…
[11.12.2016 18:44:55] [DEBUG] [Camera Thread] Nikon: Failure in Capture image! [kNkMAIDResult_NotSupported] (kNkMAIDCommand_CapSet, 33042, kNkMAIDDataType_EnumPtr, 212658040)
[11.12.2016 18:44:55] [DEBUG] [Camera Thread] Image Captured
[11.12.2016 18:45:01] [DEBUG] [Camera Thread] SGM_FRAME_AND_FOCUS complete…

Hey which Nikon camera are you using?

Using a D7000

For that camera you need DSUB cable, I believe shoeshring astronomy makes these cables. It was the newer cameras that offers direct USB interface with the API. Such as the D7100+

happy new year to everybody !

I had now the change to directly connect my D7000 with the computer running SGPro beta without USB HUB or other equipment in between an still get some issues while taking the picture. Using Win10 on the computer.

** Log snippet removed by admin for readability **


Not sure what is happening there. Please download and replace the “Sequence Generator.exe” file with this one (not an installer). It has better logging and will allow us to see more of the error.

Hi Ken,

thanks for the quick reply. I did so. Attached you will find the log an a teamviewer recording, what i did. Hope this helps. Still no exposure in the nikon.



I know what the problem is now, but not why it’s happening. The error occurs when we try to set the “kNkMAIDCapability_ShutterSpeed” to the shutter speed found in the 11th position.

[06.01.2017 14:51:44] [DEBUG] [Camera Thread] Nikon Camera: Finding shutter speed closest to 3,00s…
[06.01.2017 14:51:44] [DEBUG] [Camera Thread] Nikon Camera: Return shutter speed (i) -> 11
[06.01.2017 14:51:44] [DEBUG] [Camera Thread] Nikon: Expousre using native shutter speed at 11…
[06.01.2017 14:51:44] [DEBUG] [Camera Thread] Nikon: Failure in Capture image! [kNkMAIDResult_NotSupported] (kNkMAIDCommand_CapSet, 33042, kNkMAIDDataType_EnumPtr, 195159784)

I will make a formal beta release of shortly and it will show us what the actual shutter speed in the 11th position. Then we can try to fogure out why your camera does not want to take that value…

I had two critical problems in getting my Nikon D810 to work with SGP3 on Windows 10.
First, I could not connect to the camera until I installed the x86 version of the Visual C++ redistributable. I installed 2013, 2015 and 2017, so I cannot tell you which one was the most relevant to SGP3. So, SGP3 requires the x86 version and not the 64-bit Visual C++ redistributable.

After I was able to connect to the camera, I could not capture. I noted the following
Nikon: Failure in Capture image! [kNkMAIDResult_NotSupported]
(among other associated errors) with my Nikon D810.

I noted that the camera was set to “video” mode. I switched the camera to “camera” mode with a physical switch on the camera back and SGP3 captured a frame successfully.

Hope this helps.