Pegasus Astro Ultimate Powerbox V2

Several months ago I began using the Ultimate Powerbox V2 from Pegasus Astro. I had no problems with it. Recently however, when I start my sequence I get the following pop-up message from SGP:
Could not set switch “Pegasus Astro Powerbox Switch-0” to “Not Available!” ASCOM Switch does not understand Not Available! Aborting sequence.
I then hit “OK” and typically the sequence would start and run without issue, until last night. The sequence aborted and I could not get it to run. I tried several times with the same result.
Has anyone run into this problem? Is it SGP or the Power Box? I downloaded the software from Pegasus again and reloaded it but I still have the problem.
If someone can tell me how to attach the log file I can send it.

SGPro 4 is not compatible with the Pegasus Switch drivers. You’ll either need to downgrade to SGPro 3.2 or install the SGPro 4.1 beta (which accidentally resolves the issue).

I will try SGPro 4.1 beta. Thanks Ken. Will the two be compatible in the future?

I think so. Pegasus does some weird things with their driver, but SGPro moves to an explicit connection model (where you need to pick the switches you communicate with) and away from the implicit auto-connect to all switches model. If I remember correctly, this is where the problem lies.

Today I have also tried SGP 4.1 (725) once more. Previously that was annoying for me to use as it wanted to connect automatically to each switch it could find in the ASCOM profile. I do like the new features in SGP 4.1 but have no need for SGP to control any of my switches (and certainly not in the way it is working right now). When I read that as of 4.1 it would no longer try to autoconnect I was willing to try again.

Alas: it still only offers ASCOM Switch V2 Simulator and PrimaLuce Eagle (that I do not have and does not even appear in the ASCOM profile). Unfortunately SGP still automatically launches my DragonFly driver that I then need to stop manually when that device is not connected to my computer. Although SGP apparently tries to connect to the DragonFly (which it should not do anymore), it does not show this device in the list of available switches. What is going on here?

Will it be possible to remove these unwanted switches at some point in time and manually add the ones that actually are available?

I also do have a Pegasus UPBv2, but at least SGP does not try to auto connect to that switch (and it is also not shown in the list of available switches).

What is the issue with the Pegasus driver?

It is at least good to see that SGP is moving away from the implicit auto connect. Some more to be done then in the case of the Lunatico Dragonfly.

Pegasus has resolved the issue a while back. Basically their driver was creating a dialog box whenever a connection failed telling the user a connection failed. What should happen is that the driver should raise an error when called by an outside application. They addressed this problem a while back. If you update the ASCOM driver then you should be good to go.

You probably need to install the ASCOM driver for it if you want SGP to be able to see it and connect to it.


Thanks for the quick reply @Jared . I do have the Pegasus ASCOM driver installed though. Version 2.3 actually, which is the one that was supposed to resolve these communication issues. When I first launch the Pegasus UPB software (that provides the UDP server that is used by their ASCOM driver) and then launch SGP 4.1, it still does not show anything on Pegasus switches. OK for me as I do not need SGP to talk to my switches, but apparently not as expected then? Or would I also need to connect to the Pegasus UPB first before launching SGP? Can try that another time when back at my observatory site.

What about the Lunatico DragonFly then? Will SGP stop trying to auto connect to that device in upcoming versions? Or should I open a separate thread for that question?

Thanks for the help. I found the driver on their website. Will try it tonight!

Thanks again.


I tried again after the new download with the same results. I had to download SGP 3.2 to be able to run my sequence. It sucks to have to go backwards.


Disappointing indeed if SGP 4.1 still gives problems in combination with the Pegasus 2.3 driver. I have only tested yesterday without the Pegasus UPBv2 connected to my computer. Will test that with connected equipment tomorrow and report on results later this week.

While we appreciate the feedback, we are unable to replicate the issue here… seems to work just fine. We will need logs to help troubleshoot this issue.

Also… it is not clear whether or not you tried again with 4.0 or 4.1. The original issue described is currently an issue in SGPro 4.0, but we have made an effort to prevent it from happening in 4.1.

Ken, I tried the latest Beta version yesterday. I attached the log file from yesterday evening when I first tried it after downloading the most current software for the switch. The second attachment is the log file from the night before using version 4.0. Maybe the log files will help in getting to the problem.

I appreciate you trying to help.


(Attachment sg_logfile_20220103202506.log is missing)

(Attachment sg_logfile_20220102192344.log is missing)

@watty1959 Thanks. We don’t allow log attachments on the forum, but we have a built in tool within SGPro to assist here. Makes it easy…

@Ken @watty1959 , just wanted to report here that I have successfully tested my Pegasus UPBv2 with SGP in both x32 and x64 versions. This was with the Pegasus ASCOM driver 2.3 that I had already installed about a year ago.

SGP 4.1 does indeed not auto connect with the Pegasus UPBv2 when it starts. This happened all the time with SGP 4.0 and was very annoying as many others have already commented on the forum. The Pegasus switch is now listed in both Equipment Profile Manager as well as Control Panel and can be connected manually from the Control Panel (as long as the Pegasus UPBv2 software is also running and connected to the device).

Personally I have no need for SGP to control any of my switches as I find the dedicated switch software more useful and am able to control those with scripts outside of SGP. In the case of the Pegasus UPBv2 the ASCOM driver is also limited in use as it does not allow SGP to show custom port names and other values than 0.00 and 1.00. I can understand though that this is a welcome feature for other SGP users that do not want to rely on external scripting.

At least I am now able to start using SGP 4.1 with its new looks. Thanks for all the UI improvements Ken!

Unfortunately the Equipment Profile Manager still shows ASCOM Switch Simulator and PrimaLuce Eagle and it is not possible to hide these entries. I did find that right clicking in the Control Panel does allows to hide these unnecssary switch entries. Would be nice to have those (at least visually) removed from the Equipment Profile Manager as well.

Remaining issue with SGP 4.1 is the auto connect to my Lunatico Dragonfly switch. It would be most welcome if that can also be stopped, just as has been achieved for the Pegasus UPBv2 already.

Ill fix this

I dont understand what this means. SGPro will only attempt auto connect with switches that the sequence is using. If you dont want SGPro to attempt connection, you’ll need to alter the sequence (and possibly profile) so that it is not used.

Lunatico Dragonfly acts as two devices in one, each with their own ASCOM driver. Main function is as a Dome controller. Actually for the Shutter only driving the Roll Off roof of my observatory. It also acts as a switch allowing equipment to be powered on or off. The roof control is very important for the sequence. The switch part is not (for me). In fact I use the Pegasus UPBv2 on the mount as a switch and thus do not need the Lunatico Dragonfly (mounted on the observatory wall) to act as a switch.

SGP does not list the Dragonfly as a switch. Neither in the Equipment Profile Manager nor in the Control Panel. It is defined as an Observatory controller though, but I need to manually connect to that using the Sequencer window (same as for all other equipment, except for switches).

Would SGP be able to distinguish between Dragonfly Dome and Dragonfly Switch? Given that these are two ASCOM drivers that just happen to connect to the same device I would presume that SGP will treat them as two non-related devices.

If the Dragonfly implements an ASCOM driver for a switch and it doesn’t show in the switches list, then that is an issue.

Yes, that is correct. SGPro does not give any special consideration to combined devices and every device must be able to act as though it does not have any dependency at all on other things not defined in its contract.

ASCOM Diagnostics and ASCOM Profile Explorer clearly list Dragonfly as a Switch. Same as the Pegasus UPBv2 and the ASCOM Switch Simulator. Let me know if you need further details on this.

I installed the DragonFly driver set and it does not appear in ASCOM Diagnostics or the profile explorer… Did I install the wrong thing?


I installed this:

Dragonfly has a number of different components. The ASCOM drivers are in this one: Dragonfly6.2.0-Install.exe. There is also a Configurator which is not needed for testing the SGP - Dragonfly connection.

This is what the ASCOM profile looks like in my setup: