Problem with the sgp API guider

dear guys,

I posted a while back because my sequence had terminated unexpectedly on one of those 10 in 365 nights we have here in Wales, where the night sky is crystal clear. Jared very kindly took a look at my log and it seems guiding stopped on several occasions, but as I mentioned, sky was clear.

I have had a problem since using SGP with my SBIG STT8300m with Self guiding Filter wheel, it doesn’t always happen, but when it does, there seems to be no way out. So tonight, I’m back indoors writing this…

Here is the problem

I connect all the gear (SBIG 1st, fw 2nd, focuser 3rd and last) all goes fine. I slew and centre on M45 all fine. Main imager shows too many stars to count in the field in a 2 sec exposure.

I then start phd2 and connect to SGP api guider and All seems fine. I click ‘loop’ to start acquiring images in phd and it says star lost. There are no stars to see in the frames.

I have tried most sensible things to try to resolve this, here are some of them:
Restart everything (painful) result was the same.

Disconnect sgp api guider in phd, disconnect the sbig in SGP, run CCDOPS (sbig capture software) select ‘tracking cam’ take some repeated focus shots of 3 seconds duration - shows lots of stars (M45 region).
Disconnect from CCDOPS
reconnect to sbig in sgp
reconnect to sgp api guider in phd, loop for 3 sec exposures, not a star in sight. Come back in doors, think of reasons to be positive, make cup of tea, think about not using off axis guider any more…

I think the problem is with the SGP api guider, but I suppose it could be PHD2? it has happened to me a number of times, but if the skies were not clear, I put it down to that.

I suppose the fact that it works with CCDOPS, demonstrates that it is not a camera, cable or connection problem.

I know you guys will want log files and I’ll post the SGP and phd2 logs tomorrow when my brain starts working again.

Many thanks for your help

best wishes,

I am using the same camera (two of them, actually) and have never seen this particular issue. I assume you have tried adjusting the contrast slider in PhD and have taken and are using a dark library in PhD? Since you say you are getting an image with the tracking CCD in CCDOPS, I assume the tracking CCD is working. Have you checked the image size from the CCDOPS to double check that it is the tracking CCD?.

I know a friend had a shutter failure with his STT self-guide, so it might be useful to see if the tracking shutter is opening by setting a long track time and shining a light down the scope. If it is working you can clearly see it moving. Can you hear the tracking shutter opening and closing? If you can hear it but not see it, it is mechanical breakage like my buddy had. If you can’t hear it at all, it is more likely software or some connection issue.

I know a while back SBIG changed their definition of “Internal” and “External” guiders. Did you happen to try switching between the two in the SBIG settings of SGP?


I think that was a temporary thing they did by mistake, as I recall, maybe 5 or 6 months ago. I have always used “internal” and it seems to work but perhaps if the driver was of that vintage it might not. “Internal” works just fine with both my two year old drivers on my main PC and the latest drivers on the beta test machine.

It would seem to me that setting that wrong could indeed cause what you describe. Good thought, Jared.

Hi Both, thanks very much for taking a look at this. On reflection I think
CCDMAN is probably right concerning mechanical failure and I can check what
you’ve said too Jared. I have used the system and had some good results in
PHD2 so it probably is not software. Last night I switched between main
imager and tracking camera in ccdops, so I know i was using the correct
ccd. I have never changed (or seen) the option in SGP control panel - I’ll
look at that tonight.

Thanks too for the idea of listening and watching the shutter. I control
remotely from my house using teamviewer, but when I went out last night I
could hear the shutter clicking every 2 secs or so, so I assumed it was
working. I will check with a torch tonight.

Unfortunately we do get lots of cloud here now (never used to be so bad) so
I may not be seeing stars for a while, will keep you posted, many thanks
for thoughts,

I my friend’s case, he was imaging at my place when it happened and apparently there is a small pin that connects the shutter to it’s mechanism and that pin is what failed. In his case it failed partly open so he had a partial image. He sent his back to SBIG for repair but I have to wonder if one is handy maybe it could be fixed at home. I don’t know as we did not take it apart.

The only reason I would wonder if yours is that problem is it would not seem likely to fail and happen to be totally open or totally closed at the time but I suppose it is possible. In any case, it should be easy to see the guide shutter opening and closing if it is working so testing should be easy enough. I don’t think you would need clear skies as that could be tested in daylight by just cycling like you normally would to find a guidestar.

It is in the camera setup dialog. If you have not been to that it may be set to “none” which would probably be the cause of the problem, I would check that first in any case:

thanks both. Here is a link to a PNG file screenshot of what PHD2 looked like tonight. I think it shows a partial frame. I just pointed the scope at the wall and shone the torch on that.

The shutter issue my friend saw had stars on one side and blank on the other with a fairly sharp cutoff, This does not look like his at all, even accounting for the fact you were looming at a wall.

Could you see the shutter cycling?

No, i couldn’t see the shutter. Its a celestron c11 and difficult to see through. I will have to remove the camera at the weekend and try it indoors in the light. I’ll report back. I think i’m right though that i should see the bottom part of the phd image window illuminated?

It has worked fine in the recent past. I guided for pacman nebula and iris nebula within the last 6 weeks

Paul Kirk

I assume that was with SGP as well. Very odd as a shutter problem should not be intermittent, at least with my friend’s issue it quit and that was it. I am really at a loss.

I am not sure what you are seeing on your test shot, sometimes dark or uniform light fields look like that when stretched so I am not sure it tells us anything.

Hi CCDMan & everyone,

I also have a STT-8300, when I got it, it also had a shutter problem, and the situation was similar to you described: half of the photo with stars, and the rest is neatly covered. In looking through the lens, found the shutter does not open completely. Then I opened the FW8 cover, with a little oil, the situation had improved, STT shutter working correctly now, only at a specific point can be not fully opened.

My equipment just like yours, SGP+PHD+STT-8300/FW8, and last midnight, I first tried SGP( -> SGP API(1.3) -> PHD(2.5 or 2.4.1i), but no success. I followed the instructions in this forum to set the SGP and STT’s connection:

But the SGP could not control the PHD:

Here is the log file. Thank you so much! (19.0 KB)

Yang, from Shanghai, China

Please try the beta. There have been some changes with how we connect and talk to PHD. From what I can see from your log the SGP API Guider is talking to your camera just fine and is retrieving images.


You should use “Internal”, not “Remote Guide Head”…

Thank you all, I’ll have a try on this weekend.