QHY 268M offset per event

I just tried to set offset per event in SGP (4.0-0.700) with the most recent QHY ASCOM driver (from all in one pack and ASCOM platform but was unable to do so.

From a bit of searching, it looks like this should be working with the most up to date versions of everything - have I missed that I need a beta of some part of that?


Can you explain what you mean when you say “unable to do so”? Do you mean that the control to set it was disabled or that the gain you entered was not honored?

Hi Ken, I mean that the control used to set it was disabled.

In that case, it seems like your driver is saying that it doesn’t support gain. We can verify this in the logs if you want to post them, but your best bet may be to contact QHY.

1 Like

Thanks Ken, just to confirm before I do, because it looks more like it might be SGP, here’s the relevant SGP log snippet:

[03/03/22 07:15:20.623][DEBUG][Main Thread][NONE] Failed to fetch ASCOM camera offset list, checking min / max…
[03/03/22 07:15:20.625][DEBUG][Main Thread][NONE] Failed to fetch ASCOM camera offsets from min / max. Failed to get camera offset! : Property read ASCOM.QHYCCD.Camera OffsetMin is not implemented in this driver. (System.Runtime.InteropServices.COMException (0x80020006): Unknown name. (Exception from HRESULT: 0x80020006 (DISP_E_UNKNOWNNAME))
at System.RuntimeType.InvokeDispMethod(String name, BindingFlags invokeAttr, Object target, Object[] args, Boolean[] byrefModifiers, Int32 culture, String[] namedParameters)
at System.RuntimeType.InvokeMember(String name, BindingFlags bindingFlags, Binder binder, Object target, Object[] providedArgs, ParameterModifier[] modifiers, CultureInfo culture, String[] namedParams)
at ASCOM.DriverAccess.MemberFactory.CallMember(Int32 memberCode, String memberName, Type[] parameterTypes, Object[] parms) in C:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 242)
at ASCOM.DriverAccess.MemberFactory.CallMember(Int32 memberCode, String memberName, Type[] parameterTypes, Object[] parms) in C:\ASCOM Build\Export\ASCOM.DriverAccess\MemberFactory.cs:line 264
at ASCOM.DriverAccess.Camera.get_OffsetMin() in C:\ASCOM Build\Export\ASCOM.DriverAccess\Camera.cs:line 1779
at ub.nt()
[03/03/22 07:15:20.625][DEBUG][Main Thread][NONE] Camera does not implement ASCOM offset.

However, running ASCOM diagnostics to get the camera profile results in:

                <Default>                 QHYCCD-Cameras-Capture
                LastCamId                 QHY268M-a482ce42868a8c9c1
                max_position              5

QHY268M-a482ce42868a8c9c1CameraID QHY268M-a482ce42868a8c9c1
QHY268M-a482ce42868a8c9c1CameraXSize 6280
QHY268M-a482ce42868a8c9c1CameraYSize 4210
QHY268M-a482ce42868a8c9c1CanAbortExposure True
QHY268M-a482ce42868a8c9c1CanAsymmetricBin False
QHY268M-a482ce42868a8c9c1CanDDRBufferCapacity False
QHY268M-a482ce42868a8c9c1CanGetCoolerPower True
QHY268M-a482ce42868a8c9c1CanPulseGuide False
QHY268M-a482ce42868a8c9c1CanRemoveRowNoise False
QHY268M-a482ce42868a8c9c1CanSetBin11 True
QHY268M-a482ce42868a8c9c1CanSetBin22 True
QHY268M-a482ce42868a8c9c1CanSetBin33 True
QHY268M-a482ce42868a8c9c1CanSetBin44 True
QHY268M-a482ce42868a8c9c1CanSetCCDTemperature True
QHY268M-a482ce42868a8c9c1CanSetCFW True
QHY268M-a482ce42868a8c9c1CanSetGain True
QHY268M-a482ce42868a8c9c1CanSetOffset True
QHY268M-a482ce42868a8c9c1CanSetQHY5IIGuidePortOnOff False
QHY268M-a482ce42868a8c9c1CanSetSpeed False
QHY268M-a482ce42868a8c9c1CanSetTransferBits True
QHY268M-a482ce42868a8c9c1CanSetUSBTraffic True
QHY268M-a482ce42868a8c9c1CanStopExposure True
QHY268M-a482ce42868a8c9c1CurrentReadMode 1
QHY268M-a482ce42868a8c9c1ElectronsPerADU 1
QHY268M-a482ce42868a8c9c1FullWellCapacity 65535
QHY268M-a482ce42868a8c9c1Gain 56
QHY268M-a482ce42868a8c9c1HasCooler True
QHY268M-a482ce42868a8c9c1HasShutter False
QHY268M-a482ce42868a8c9c1MaxADU 255
QHY268M-a482ce42868a8c9c1MaxBinX 4
QHY268M-a482ce42868a8c9c1MaxBinY 4
QHY268M-a482ce42868a8c9c1MaxExposure 3600
QHY268M-a482ce42868a8c9c1MaxGain 339
QHY268M-a482ce42868a8c9c1MaxOffset 255
QHY268M-a482ce42868a8c9c1MaxUSBTraffic 60
QHY268M-a482ce42868a8c9c1MinExposure 1E-06
QHY268M-a482ce42868a8c9c1MinGain 0
QHY268M-a482ce42868a8c9c1MinOffset 0
QHY268M-a482ce42868a8c9c1MinUSBTraffic 0
QHY268M-a482ce42868a8c9c1Offset 6
QHY268M-a482ce42868a8c9c1PixelSizeX 3.76
QHY268M-a482ce42868a8c9c1PixelSizeY 3.76
QHY268M-a482ce42868a8c9c1PresetGains 102,102,0,56,14,56,0,0,0,0
QHY268M-a482ce42868a8c9c1PresetIndex 5
QHY268M-a482ce42868a8c9c1PresetKeywords DSO,Planetary,Gain 0,Gain 56,Gain 14 (RM3),Gain 56 (Bin 2x2),-Undefined-,-Undefined-,-Undefined-,-Undefined-
QHY268M-a482ce42868a8c9c1PresetOffsets 76,0,25,25,25,6,0,0,0,0
QHY268M-a482ce42868a8c9c1RemoveOverscan False
QHY268M-a482ce42868a8c9c1SetCCDTemperature -10
QHY268M-a482ce42868a8c9c1StepExposure 1E-06
QHY268M-a482ce42868a8c9c1StepGain 1
QHY268M-a482ce42868a8c9c1StepOffset 1
QHY268M-a482ce42868a8c9c1StepUSBTraffic 1
QHY268M-a482ce42868a8c9c1TransferBits 16
QHY268M-a482ce42868a8c9c1USBTraffic 0

Note that “CanSetOffset” is True and that the preset offsets from my presets (I guess from manipulating the offset via the ascom drivers own properties window) show up.

Can you confirm whether this indicates that SGP is somehow misreading the capabilities, or is it definitely a QHY issue despite the driver reporting those capabilities in ASCOM diagnostics? To confirm, as referred to above, I can definitely set the offset manually via the ascom driver properties (accessed through the wrench icon in SGP), I am just having the issue when trying to do it “per event” in a sequence, I click the down arrow next to the event offset setting, and get only “Not Set” and “NA” as options, with no ability to select or type an offset.

Hi Ken,

Disregard, sorry, I just did some fooling with it, reinstalled some drivers etc, and now it works, I have no idea what was broken before as I didn’t change versions of anything, I simply reinstalled from the existing decompressed temporary folder that the QHY AllInOne installer creates (with the individual installers contained within it for all the various driver components), but now it is working.

Thanks for the help.