RainbowAstro RST-135 and RST-150H vs SGP & PHD

Hello Everyone,
I’m using SGP for imaging with my mount RainbowAstro RST-150H.

I’m often having connection problem with the following message from the ASCOM driver: “Connection fail. Please check the comm port". My normal night is 2 to 4 hours of imaging, but eventually I get the message of connection fail, and the mount stops to guide.

I already send my mount back to RainbowAstro, they replaced the control board. I also replaced the computer (3 times), change cables and still having the same problem. So, it seems the hardware is ruled out.

Is someone using SGP & PHD to image with the RST mount?

Do you have similar problem?

Thanks in advance for any help.

I have just bought a Rainbow - I have been using it through ASCOM without any issues. A couple of ideas - is the USB/Power cable secure, as it swings round, it could be intermittent. Other things to look out for are USB sleep mode in Windows. Have you gone into advanced power settings and disabled any USB sleep mode?

1 Like

I have used SGP with an RST-135 for a year. It has worked flawlessly. I always connected the USB directly to the NUC that I use.

Thank you for the advices.
I’m will change again the cables and give another trial. The USB sleeps I have ruled out.

The interesting facts:

  • SGP works perfectly with my other mount (Avalon M-Zero).
  • The RST-150H seems to works OK with Maxim DL.

I’m open to ideas, it’s really annoying to lose good clear nights :frowning:

Thank you,

A couple of further thoughts. I do not seem to be able to pulse guide with PHD2 through TSX via its ASCOM driver. I have to connect PHD2 directly to the hubo ASCOM driver. It then works.
There are two modes on the Rainbow, LX200 and Rainbow protocols. I’m using Rainbow protocol.

Hello Chris,
I’m also using the Rainbow protocol, I think the LX200 is for wifi connections, e.g.: SkySafari. But I test it again.

It’s the kind of annoying problem, because I cannot know immediately after test if it works or not, I need to let some hours working to after have the error.

What I known by now is:

  • PHD2 alone seems to work OK
  • Maxim DL seems to work OK
  • It’s not the cables
  • It’s not the USB ports or computer (they worked OK with another mount)

At this moment, I believe it’s a software related problem.

Did you try SGP with another guiding software? Do you have any suggestion?

Thank you,

I have only just got this mount and have been mostly becoming familiar with its operation and working out the best guider settings. Last night I used the Hubo ASCOM connection with TSX to do a 100 point TPoint without any dropouts.
I have not used SGP specifically and I’ll set it up to try imaging for an extended period (weather permitting). I am also using a NUC, connected to a Pegasus powerbox on top of the telescope.

I didn’t try The Sky X yet.
I took a look in your book (great book by the way). The Sky X is one of the most integrated softwares in the list. What are you thoughts about it?

Thank you,

TSX came with my Paramounts and is needed for their operation. I use it like a sophisticated ASCOM driver :wink:. Its imaging module will do simple sequences but I use SGP for more “intelligent” acquisition. I use its imaging module for doing some experiments and sky modeling (TPoint). TPoint also works with other mounts, including most ASCOM mounts, and is super-easy to use and very good, much better than the others I have tried over the years. I get centering to a few pixels in SGP with one correction cycle on the MX/MyT. The Rainbow is not too far behind.

I’m running a dummy sequence indoors, without PHD2 (obviously), just a sequence of targets without centering and image sequence. The Hubo driver is a hub, so I have SGP and TSX connected to that driver, rather than interface to the Hubo through TSX’s own ASCOM driver.

Before to go for TSX, considering it is pricey :roll_eyes: , I still ruling out the possible causes.

I’m testing now connecting the through ASCOM device hub. Let’s see what will happen.

My next step is try another auto-guiding software, replacing PHD2. I was thinking in MetaGuide, but I’m having trouble to have my guide-camera connecting to it.

No great results for the moment.


Hi - there are some foibles with the ASCOM operation. Multiple connections to it seem to mess things up. I cannot get it to home if TSX is connected. It’s running now for over two hours without issue. Guiding with PHD2 at high frequency. I also do not seem to be able to do pulse guiding through TSX either, which is odd. Could be TSX.

I ran an all-night indoor test with Maxim DL with positive results.
There is something in PHD2 or SGP that is killing the connection of the ASCOM driver.

I imagined the wrong guide speed could have an impact, but the settings are right. In fact there not a lot of settings that could cause a communication problem. I’m puzzled :face_with_raised_eyebrow:

I had a clear night last night and ran SGP/PHD2 for several hours. No problems in the disconnect department. I did have major issues with both 32-bit and 64-bit versions of SGP - the Profile manager would not open and I could not do ‘new sequence with profile’, even though I could see the profiles. I reckon, over many beta versions, something got corrupted along the way and I did a full SGP uninstall/install, which fixed the problem.

I am using a QHY178 guider, with 0.2-0.5 second exposures and a USB speed setting of 30. I wonder if that last bit might be fighting with mount commands on the USB interface? Of course, the other thing is the USB hub. One application may be putting out more traffic than another. My USB 3.0 hub is the Pegasus PowerBox. I did notice that my USB connector is quite wobbly in the mount and have ordered one of the coiled USB cables and will secure it, to lessen chances of disconnect during slews.

I had several ASCOM issues (like pulseguiding) when I tried to use TSX as the telescope hub and found I had to connect TSX, PHD2, SGP and a mount utility I wrote, directly to the Hubo driver.

@Pontes - you are right it is the connection through ASCOM that is failing- your earlier screenshot shows it - it failed to communicate. Just because other apps work may be purely coincidental. It is certainly unusual when MDL works and SGP does not! I abandoned MDL for that reason.

I am also running the latest version of ASCOM platform and the drivers.
I would also check for updates for the USB-serial device and avoid low-cost USB hubs and long cables.
I am not a fan of the USB connector position on the mount and just found a coiled cable that makes a neat flexible arrangement between the mount and the hub on the scope.

I was mailed a link to a revised ASCOM driver (to fix a different issue). It has not made it to the Rainbow website yet. Here is the link to the download that Rainbow provided me. It might work.

Hi @buzz,
Thank you for the new driver!! Do you know what are the changes on it?

I believe that the source of my problem is found :smiley: :dizzy:
I ran several all-night indoors simulations with the following results:

  • SGP running alone connected to the mount works OK
  • PHD2 running alone connected to the mount works OK
  • PHD2 + SGP running together fail after some hours in 100% of times I tested.

My conclusion: something is wrong in the PHD2 Server, when it is connecting with the RST mount. That is not exactly a Root Cause, but was good enough to isolate the problem.

I was running PHD2 2.6.9 and SGP 4 in the version 32bits. I moved to beta version 64 bits: SGP 64-bit and the problem finally is gone.

It’s interesting that this problem only happens with RainbowAstro driver, the other ASCOM drivers I never had a problem. Additionally, I changed the PHD2 to the 2.6.9dev4, just to use multiple stars.

My cable management good be better, but is not too bad. I’m keeping USB cables as short as possible to avoiding them swinging around. Thank you for the ideal of the coiled USB cable, I will look for one to buy :wink:

The change I know about is the correction of the guide rate setting - it was not in the right units.

I am using pulseguiding with PHD2, rather than ST4. The 64-bit version will pick up on 64-bit drivers. Not sure what PHD2 is - it may be different as it is working in server mode. You can tell by where it is installed. This is my work in progress assembly with NUC and Pegasus unit. Even with the pier extension, the filterwheel is still hitting the legs and I think I will need to look at the StarField tri-pier

Hi @buzz,
We are using the same tripod you are :slight_smile:

I bought my RST-150H with a half-pier extension, however with the adapter for the Gitzo tripod. I create a drawing and ask to a machine shop for an adapter to use with my Avalon T-Pod.

I see your problem with the filter wheel…
What about to machine an extension pushing further up the mount? How much space to get the filter wheel above the tripod legs?
I could be a lot cheaper than buy another tripod.

yes - the extension you see is one I designed myself. I have a local machine shop that makes the adaptors for me too. Very useful. The three rods are 150-mm long. I could just ask for some 300-mm ones. I will need to check but I think that the diameter of the filter wheel, at certain orientations, is wider than the mount offset, so no extension would be long enough. The answer may be to have a spacer on the saddle, but I would have to counterweight it more.