SGP cannot find Robofocus

I have quite a bit of experience with SGP and Robofocus, on several different rigs. But this new installation cannot seem to find RoboFocus out there.

I installed RoboFocus with fresh downloads several times. Problem remains. I could find no answer in the Forum.

I go to configure Robofocus it in Equipment Profile, and among the focuser options there is no “Robofocus” (as there is in my other three Robofocus installations). And, I cannot find it in the pull down for the connection area in the Sequencer. In other words, SGP does not recognize that Robofocus is out there.

Nor does ASCOM Device Hub. It acts the same way, and there is no Robofocus in the pull downs for configuring into the focuser section.

When I click on the Robofocus program, the actual program does not start. It places an icon in the tray at the bottom of the screen, but otherwise does nothing.

If I use the file folders, navigate to the program, and tell the computer to run Robofocus, AS AN ADMINISTRATOR, it works perfectly well. I can move the focuser by pushing the buttons on the screen saying to move in or out. It is fully connected and operating.

Sounds like I have the wrong driver (although I downloaded the only driver I found on the Robofocus website and installed it as I always have on my other computers through the years).

The problem is the same whether I use the 64 or 32 bit version of SGP. I am in SGP 4.2.942 in both. I have not tried in SGP3. Windows 10 Home.

Anybody have any ideas?


It sounds like maybe it was installed AS the administrator or maybe through another user account? Have you tried uninstalling the Robofocus driver and reinstalling? If you run SGP as an Admin does it pickup the driver (as you know you should not have to do this but just trying things from a troubleshooting perspective).


…another thing I would check is that the actual COM port being used is as expected in the RBF settings.

Thanks for the suggestions, folks.

I think we have something as far as different user accounts. I have not had time to explore it, but it sounds sensible.

I signed on just now as I usually do (which I believe makes me an administrator). And then started SGP4/32. It still did have RoboFocus listed.

I signed into RoboFocus (the separate program apart from SGP) and used it AS AN ADMINISTRATORsuccessfully to focus the scope. So I know the settings (comm port, etc.) are proper, and working. But, I cannot sign into that program as a regular user.

I started the mount in SGP. Curiously, as I called up PHD2 to work, it could NOT connect to the Mount. THis afternoon as I experimented, SGP and PHD2 had no problem connecting together. But now, PHD2 would not connect because another program or user was using it. Well, SGP was. But they are made to work together.

At any rate, I got it kludged together (by disconnecting the mount in SGP) and it is taking pictures. They were not autofocused. And I could not use the scope to plate solve and center the target.

I’ll work on it a bit more tomorrow. For tonight I am happy my guiding and acquisition is working. (I wanted to test a new mount control box since my old one died!) It appears to be working. I can work on the rest of the functions later. First I must study what all this administrator and user stuff means, and see if that is the real problem.


Here I am a few more hours of work later…and still no progress. Removed the RoboFocus program and reloaded. Made sure both SGP and Robofocus programs could be run by any user, (admin, or otherwise)—or at least I think I did that. I had never worked with Permissions before. And besides, I am the only person who has ever signed in on that computer since did a complete wipe and restore of Windows.

So----I’m off to explore.

I’m thinking of restoring to SGP 3 32 and see if that makes a difference.

Remember, the RoboFocus program works when run as an administrator. So, the driver must be there, and the connections right. It just that SGP does not see it (Nor does ASCOM hub!).


Of the ASCOM hub is not seeing it then that sounds like something with the ASCOM driver either not being installed or not being registered correctly.

You can probably leave SGP alone until it starts showing up in the ASCOM hub. You can also check the ASCOM Profile Explorer and see if it’s been registered there.



Thanks very much for hanging in there with the advice. I have come to the same conclusion regarding that it is not an SGP issue, since I have the same problem with the ASCOM Hub. Both of them have pull down selecting boxes that list the focusers they see. And neither see RoboFocus.

Unfortunately, I do not have sufficient understanding of registries, and getting the driver into the registry, and all that. It will take me a while to explore.

Meanwhile, there is one fly in that theory. RoboFocus itself works. That is, I can focus by clicking on the appropriate “in” and “out” move buttons on my screen in the RoboFocus program, and the focuser moves. So, the focuser must have some kind of driver I should think. But, you know, I may not know what a driver really is. I always thought of it as a small computer (as opposed to human interface) program that translated what was on the screen into what the device needed to know.

I have a request in for help at RoboFocus. While I am waiting for that, I am going to see what my other computers have…they work with RoboFocus and SGP. Maybe that will tell me something.

Thanks again.


So I’m assuming you downloaded the RoboFocus Version 3.2 from here:

The good news is you’re not crazy…that download does not appear to contain an ASCOM driver…it only has their control program. I also installed it just to see and I have no RoboFocus ASCOM device that was installed. Furthermore I haven’t had a lot of success finding a RoboFocus ASCOM driver. You may need to contact the manufacturer and ask where to find their ASCOM driver.

There are 2 levels of “driver” here. 1 is a hardware level driver…that is the thing you currently have. Then there is the ASCOM driver. This is the piece that most applications talk to and the ASCOM driver then relays the commands to the hardware driver. A lot of manufactures bundle these together so you download them both at once and install them at once. Some will have a hardware driver and an ASCOM driver separately (as seems to be the case here).


The good news is you’re not crazy…

Well, perhaps not on this issue.

And it was one of the things I was beginning to suspect. —That there was something wrong with the download. It was never finishing the installation.

Apparently ASCOM has made a change in the way they do things, and no longer have all the drivers on their website. They depend on the manufacturers to have their drivers.

And, yes, this is where I was getting the downloads. I went out to my “portable” rig to see if I still had the download I used on that (which worked perfectly). But it was gone. I shall see if I still have it on my desert observatory rig.

At any rate, I have contacted the manufacturer. That was Friday, and I figured he or she deserved at least the weekend to respond. I will call them tomorrow if they do not email me, and let you know what I find out.

And I specially want to express my appreciation for you going out of the way to download the thing and check it out. That is extra effort.


From their user manual.

“ASCOM and Scripting
The RoboFocus control program is available with full ASCOM scripting interface. We are unable to
provide training or examples in scripting; however, ASCOM can be pursued via the WEB (simply search
on ASCOM). We fully expect that very soon customers will be using this facility and sharing it with other
users. Please contact us for details.”

I read that as well. I’m not sure if the expectation is that people use the scripting interface (no one does to my knowledge). But that package does not contain an ASCOM driver.


I am not 100% sure…but went looking in my downloads and have this one: (link to DropBox) Dropbox - - Simplify your life

Thank you Jared and Kinch for your comments.

Unless Robofocus has seriously changed something, I am sure what I have done should have worked. After all, I have used some six computers at one time or another and two different Robofocus handboxes, and at least four motors. They all worked by simply downloading their “driver,” extracting and clicking “Setup,” and so forth. None of them required any scripting.

I got out one of my old laptops with just one such installation, with the entire download folder from 2012 and tried that. (Come to think of it, why don’t I just put that in the obs?—I know it works with Robofocus.)
I tried Kinch’s suggested files from the Dropbox, which I appreciated.

In both cases, the problem remains. In both cases, the computer did the same thing, and left me with no driver showing for Robofocus in either SGP or ASCOM Hub.

So------it is something bigger than that. I suspect it is something in the registry that has old files that are not working, but not being replaced when I reinstall the program.

I still have a call in. Their tech was busy, but said I would get a call back.

I’ll report back when I get something.


I honestly think it’s that installation package and not something on your machine. I’ve also installed it locally and have no focuser driver showing up for it…this is from the Profile Explorer that installs with ASCOM. There is simply not an ASCOM driver being created for it.



…but is is in mine:

@kinch can you bring up the properties dialog for that driver?

I’ve updated my ASCOM and installed the driver from your dropbox and I’m still not getting it to show up.


Here’s one I found. It does install a RoboFocus ASCOM driver…looks pretty old and only supports 32bit applications.



At the moment I am not controlling the RoboFocus motor via the RF controller. (I am using an Armadillo Seletek - dual controller - by Lunatico). So I cannot go too deep on what extra you may need. However - the screen shot shows the last settings I adjusted via the RF controller and properties on my desktop shortcut.

…and here are 2 screen shots of the properties for the application in C:ProgramFiles (X86)

I did not get a phone call back from Florida (RoboFocus). I called them again about 1:30 (California). I think they closed. I’ll try again tomorrow.

I uninstalled the program (again) cleaned my registry of every problem related to RoboFocus, and ran the setup program again with no change in the way RoboFocus reacted (still could not be found).

Yes, this is an OLD program. I do not know when it was last updated, but as I said, I have gotten it to work on many of my other computers over the past 15 (?) years. Latest setup was probably my mini computer about two years ago.

I’m going to install my older laptop and see if it all works as it should. Then, at least, I do not have to worry about how long it takes to fix the other one I am trying to get up to speed.

Again, thanks for your efforts. Will report back when I get contact with RoboFocus support staff.