SGPro does not launch anymore

Hi all,

I discovered today that SGPro is not starting at all.
Of course I have found some similar threads where e.g. the user file was deleted or ASCOM was the root. So I deleted the user configs, reinstalled ASCOM and still nothing can convice SGPro to start.
When I click the SGPro app on my desktop just shortly the mouse pointer changes the form and then back to normal but no SGPro is starting.
Does anyone have a good idea what I can do?

I certainly do not know if this is the case for your issue. I am assuming that SGP worked prior to this incident. Sometimes programs (ie, SGP) don’t close properly and are still running in the task manager and do not show in the applications bar below. Ctrl + Alt + Del and select Task Manager, scroll through the running task and if an instance of SGP is running, close it and then try restarting SGP. Otherwise, maybe try rebooting the PC. Just throwing this out there for you to possibly check.

I already restarted and before checked the task manager. The task manager is not listing SGPro; therefore I assume that it is not running at all.
Also after the restart and the attemt to start SGPro I checked the task manager. Still no SGPro listed.
I further tried to install an old version but also this did not show any improvement.
Hopefully there are still some ideas left? :slight_smile:

un-install SGPro, but before re-installing, rename the config directory C:\Users\YOUR_USER_NAME\AppData\Local\SequenceGenerator to C:\Users\YOUR_USER_NAME\AppData\Local\BAD_SequenceGenerator_BAD.

After re-installing a new config directory will be created & with luck it should run ok, but you will need to re-create the user & equipment profiles.

Thanks for the hint!
I will try it tomorrow, time for the bed now. :slight_smile:

Please try the steps here to reset the SGP config:

Thank you,

Hi all,

I renamed the subdirectory as said above. Then I de-installed the existing version and installed the latest one after.
But still there is no starting of SGPro. I checked the subdirectory under “local …” and there was no new suvdirectory generated for the user file. Is that possibly an indication where the problem may be?

And yes, the file explorer was already ticked at the “Hidden items” tab.

And sorry, yes it is a Win10 system.


Do you have the .NET 4.7.2 or greater framework installed? What version of ASCOM do you have installed?

Thank you,

Sorry for the late reply.
I have the .NET 4.8 installed.
ASCOM is the 6.4 version.


I had a similar problem, except that SGPro never started once after a brand new first-time install. I ended up getting it going by uninstalling the DOT NET frameworks 3.5 and 4.8, and the C++ runtimes back through 2013. Then I reinstalled DOT NET FW 3.5 and 4.7.8, and let the C++ runtimes install on their own with apps that needed them. And finally, SGPro started and has been working fine since (though that’s only a couple of days so far).

I am having exactly the same problem. Fresh install of7 Windows 10. SGP will not launch. I have removed C++ back to 2010 and .NET Framework 4.8 & 3.5. Reinstalled 4.8. Windows refuses to download 3.5. Reinstalled SGP but still fails to launch. Any ideas on adding .NET Framework 3.5 and is it needed.

3.5 should not be needed. Is a SGP log being generated at all?


Thank you in taking an interest. No. the program is aborting during start up. I never see any thing present it’s self. I have attempted to start with Task manager open. It doesn’t show anything either.


I upgraded to Ascom 6.4 SP1 tonight and now SGP won’t lauch. I’ve rebooted the computer and uninstalled SGP and then reinstalled it but all to no avail.
I’m basically dead in the water here.

I’ve tried the “nuclear option” described previously in the thread but to no avail. I’m running Windows 10 home on a Dell XPS 15 9560. I’ve got the following DOT.NET version installed:
I’ve also tried uninstalling version and installing a previous version all to no avail.

SGP has worked flawlessly on my machine since I purchased it 3 years ago. I updated my ASCOM yesterday to version 6.4 SP1 following an update to version 3.1 of the driver for my Optec Focus Lynx focuser and since then when I can’t get SGP to open. Not even a splash screen.

Has anybody had a similar issue ?

thanks for your help.


Yes I also just installed ASCOM 6.4 after a Windows 10 reins

Can you check to see if logs are getting generated? Even if you never see anything that doesn’t necessarily mean that SGP didn’t write a log. You can find them here:


There have been quite a few cases where the ASCOM 6.4SP1 install has been corrupt and running the installer and using the “Repair” option has fixed it. Be sure to restart after installing ASCOM versions as well.

Thank you,

I repaired ASCOM. Uninstalled SGP and reinstalled v2.6.1.398. Then rebooted the computer. Opened task manager and hit the SGP icon. Got a rotating circle for 1.5 seconds. No activity in task manager and no sign of the program. Looked for log but folder \AppData doesn’t exist.

So, it looks like ASCOM 6.4SP1 was released 22 days ago. Do any of you with this problem have the previous version that you can go back to?

What version of windows are you running?

Thank you,