SGPro Sudden focusing issues

Its been several weeks since I last imaged I setup over the last week and am having a difficult time focusing. I downloaded all updates and setup as normal. Good skies no clouds.

I have noticed when I’m in a region of the sky that does not have a large nebula or galaxy… focusing works great. Soon as an object is in the frame focusing goes to hell. HFR that is normally below 1 is now in the 3 to 5 range.

Equipment :
Moonlite Nightcrawler focuser
Tak 106 scope
QSI camera
SGPro -

I tried using MaximDL and Focusmax and focus is normal.
I tried NiINA and it focused as expected.

I have checked my settings and the don’t appear to have changed.
300 steps
9 and 7 data points
min star size - I have tried 4 - 5-6-8-10 no luck.

Anyone else having any issues or anything I should check?

Any help is appreciated.

Doubt that it is the focuser since I am using the same focuser and scope and have had few , if any, issues. This can happen due to an object occupying too large a portion of the FOV and too few stars but I seldom see it with the 16200 based camera on my setup due to the fairly large chip.

I know it’s not the focuser… it works fine in NINA and MaximDL with focusmax. I was wondering if maybe it was an update. Very Strange for sure… the focuser is rock solid and has always worked. I will try again this week.

Not much has changed in the way of focuser control. Is it the ability to control the focuser or is it something with auto focus that is problematic? Can you share a SGP log where this has happened?

Thank you,

Thanks… i will post the logs when I can get them. I’m pretty sure its something I did… I just do not know what.

I ran into the same problem a couple of nights ago with the Moonlight Nitecrawler and SGP (latest version). My settings are the same (300 steps, 7 or 9 datapoints). I increased the exposure time per image, but without success.


Well… I have not been able to get out since my original post. I’m going to give a try with current version of SGP. If I have the issue again I will revert to an older version… if for no other reason than to rule that out.

Just for another point of reference…I have a Nitecrawler on my remote setup…use it frequently with 0 issues. One thing that I have noticed is that sometimes the rotation can get lost. Ron has a firmware update for this but I have yet to send my NiteCrawler in as it’s a trip to get it and mail it. From my understanding this has been fixed for a while…I just happen to have one of the first set of NiteCrawlers.


are you running lates version of SGP?

Haha, yes…as the developer of SGP I’m generally running the latest :smiley:


I have this setup: FSQ-106, Nitecrawler, camera with 16200 chip.

My settings:
Exp time 3s, Bin 1x1, Data Points 7, Step Size 250, Min Star Diam 3, Disable Smart Focus Off.
Work stably.

The focuser is not my concern as it works without issue in MaximDl and NINA… what version of SGPro are you using? I’m wondering if I changed something (most likely) or an SGPro issue… I have those before on updates alsol.

We’ll need logs to look into things with an idea of what you’re seeing. Is this more of an auto focus issue? The description sounds like maybe it’s something with your auto focus but the title seems like it’s your focuser not working so it’s a little confusing.

Thank you,

Good point … I modified the title.

Soon as I can get out a gain I will grab the log files… Like I said probably user error and maybe the log can help Identify,.

Sorry I have not posted earlier… I hav had continued issues.

I hae switched to NINA, I miss some of he automation but the focus routine works.