Sky Flats - Need Help Understanding how to setup Sky Flats up

I have not had any luck getting SkyFlats/AutoFlats to work for me. I am sure I don’t understand how to set it up to run. I would like to run the SkyFlats/AutoFlats at dawn. I use the “AutoFlats” Dialog box and select “Schedule Sky Flats as part of this sequence”. It then opens the “Capture AutoFlats” panel which I fill in Steps 1 & 2 as required/needed. Step 3, Start AutoFlats at dawn, End Autoflats when too light. Step 4 Automatic (for sky flats). down at the bottom right "Preview the AutoFlats run schedule for, I select “Before” in the pull down, select Ok. But I don’t see anything in the sequence that indicates AutoFlats will run.

Also, as a side note, I typically like to park the scope and do bias and Dark frames at the end. Should there be some kind of feedback in the Sequence window indicating AutoFlats are scheduled to run.

I tried a couple of different things over the last two nights trying to get AutoFlats to run but I just can’t figure out what I am doing wrong. I there a detail “how to” document someplace that would help me?


This beta feature, for better or worse, has external documentation at the moment (the docs are also in beta). You can find them here:

To answer your questions directly…

Currently, this indicator is in the status bar. AutoFlats doesn’t really have any indicator with the “main sequence”. That said, it may be a good idea to add an indicator in the in the target list.


The screenshot indicates the sequence WILL NOT run dusk flats and WILL run dawn flats.
I am noticing as I draft this that these indicators seem to be at least partially broken. I’ll fix this…

Did you make sure to enable the Dawn Flats like so:

This is just a means by which you can see what AutoFlats will capture when it runs. In the scenario you describe, you would be interested only in the “After” sequence preview.

Also, before just running AutoFlats as part of your sequence, I highly recommend running AutoFlats as a standalone tool at least one time and then work on automating it.

Thank you @Ken for the AutoFlats document link.

As you pointed out, I believe I had everything setup correctly but maybe I missed something. I’ll read the AutoFlat document to try to better under how to work with this new feature and do as you suggest, run AutoFlats as standalone to get better acquainted.