Unhandled Exception in Elbrus Plate Solve

Unhandled Exception in Elbrus Plate Solve.
I have been using SQpro for a few years, and Elbrus Plate Solving worked every time until a few weeks ago. Then a complete failure with this message (it’s with any FITS.file).

Unhandled exception has occurred in your application. If you click
Continue, the application will ignore this error and attempt to continue. If
You click quit, the application will close immediately.
Retrieving the COM class factory for component with CLSID
(EC34FFB3-39DD-4585-B6B8-1900ED7E7687) failed due to the
following error: 800700c1 is not a valid Win 32 application. (Exception
from HRESULT: 0x800700C1).

I know this has been discussed before. But I cannot fix it. I have reinstalled using the Elbrus Installer (about ten times), Checked and repaired the Microsoft.net. I am running it as administrator. I have used a Registry Cleaner. I have done a System Restore to before the problem started. Nothing works. The frustrating thing is my wife downloaded it on to her PC. and it works perfectly. It also works on my PC. In the house, but not on my laptop in the observatory. I assume it is some kind of Windows Registry problem. I am on windows 7. (latest version of SQpro).
Any help would be appreciated.
Thanks Adrian


This error means the Elbrus COM server was not registered with the OS. What OS are you using? How did you install Elbrus? Where did you install Elbrus?

Also… you will need to ensure that you can get Elbrus to work outside of SGPro before we can proceed with further trouble shooting here. If, for a given image, you can solve it from within the Elbrus app, but not from SGPro on the same computer, we can troubleshoot further.


Hi Ken.

Thanks for getting back to me so quickly.

I am using Windows 7.

Elbrus is installed through the SQpro, Elbrus installer.

It is downloaded to My Documents (in a folder that I create there).

I can Plate Solve within the Elbrus app.

Thanks, Adrian

Ok, Thanks. Do you have multiple copies of Elbrus installed? Did you ever attempt to install it anywhere else? Sometimes Sequence Qenerator Pro will be pointed to a server registration that no longer exists.

You can try 3 things and then I am out of ideas:

  • Open a command prompt (terminal) as admin. Navigate to the folder you installed Elbrus (the folder that contains Elbrus.exe), then run:

    Elbrus.exe /regserver

  • Turn UAC in Windows 7 off completely

  • Run Sequence Qenerator Pro as “Admin”. If this works you will also have to run all other applications interfacing with SQPro as “Admin” also (like PHD2).

Hi Ken.
I do believe you have fixed it.
I deleted Elbrus out of My Documents, then went into the search and sure enough a
few Elbrus files still existed. I went through deleting all these. I then reinstalled using a
simpler path, just C:\ Elbrus (instead of My Documents). Everything is running as
Administrator. It now seems to work!
Great Program and as always great service, much appreciated.
Thanks. Adrian