Using my Astrotortilla settings in ANSVR

dear all

I have been using Astrotortilla for some time and I have tuned it for my setup so that it works reliably. Unfortunately i can’t get it working in SGP with the ansvr settings.

these are the settings which work reliably for me in AT:

downscaling 2
scalemin 1 (AT refines this on solving to 1.2)
scalemax 3 (AT refines this on solving to 1.5)
scaleunits arcsecperpix
scale refinement 0.1
search radius 30 (i can make this lower too)
custom options --sigma 100 --no-plots --overwrite -N none -c 0.01 --objs 200 (I can put all these custom options in ansvr no problem)

jnow or j2000 ( I use Jnow)

My setup in AT solves a 10 sec image of Altair area of sky in 6 secs.

so my question is, can ansvr accommodate these settings?

thanks for any help with this,


Most of those settings are available in the ansvr settings screen:
Start => Local Solver => Ansvr Settings

downscaling 2 is “Downsample factor” in the ansvr settings.

Scale min/max are determined by “scale error estimate”. For your settings, assuming the scale is 1.35, your scale range is 1.35 +/- 11%, so you would use 11% for the scale error estimate ansvr setting. You could probably reduce that a bit and go with the default, 5%, which would limit the scale to 1.28 … 1.42. Just make sure you set the image scale to 1.35 (or whatever your exact scale is) in SGP.

Search radius cannot be set as SGP does not send any location hint; lots of testing shows that the location hint does not make much difference in speeding it up. The scale hint and scale error estimate do make a huge difference speeding it up.

your custom options:
--sigma 100 – that is “Noise level / set the noise level in the image” in the ansvr setings
--no-plots – not applicable; ansvr always disables the plots automatically
--overwrite – not applicable, ansvr always uses a unique temporary location
-N none – not applicable, ansvr always disables this automatically
-c 0.01 – you can put this in “Additional solve-field arguments”, but 0.01 is the default value so no point actually
--objs 200 – that is the “Objects” setting in ansvr settings

Hope that helps,

thanks Andy - brilliant, I will give this a try asap.

best wishes

I have now successfully solved an image, so that’s a good start, thanks for help with settings.

Can I just check in SGP in control panel> platesolve it says:

attempt to recenter/ rotate ( I put in 1 ) times
until error is less than (I put 50 pixels)

and rotator error is less than xxx deg

the last part uses ‘and’ , but I don’t have a rotator. What will I set the value to?

thanks for help,


Don’t worry about it. If you don’t have a rotator selected or connected SGP won’t bother attempting to correct the rotation.


thanks all

I saw some stars tonight, so I tried the plate solve (local ansvr) and it solved and said it sync’d the mount, but it doesn’t do the sync. I get an RA and dec with a message which says confidence 50 etc.

I had told the scope ( to goto M15, then plate solved. I took an image but M15 wasn’t in frame.

Have I missed something?

thanks for help

i use Astrotortilla before SGPro…ca i use it also in SGPro? thats right understanding? that would be great…solv Images in under 10 Secs…


Hello Werner,

Astrotortilla is based on the plate solver. There is a package available to install on your PC and use it from SGP:


Hello, i installed it already, great! but why is this not an Option in SGPro from start…i “lose” 3 nights of tryin with elbrus…
sad but true…will test it at tuesday…


It will probably be worth the time to get Elbrus working in addition to the local Elbrus solves much faster then ansvr, and it is very fast and effective to use Elbrus as the primary solver and ansvr as the fall-back. If you want to post some information about the problems you were having with Elbrus we can probably help you out. I suggest you start a new topic rather than piggybacking on this thread.


I’ve used the Ansvr plate solver with the AstroTortilla front end by changing the Cygwin Shell entry in the AT set up but don’t know if something similar could be done to specify the location of the AT version of It’s possible that nothing would need to be done if the AT version of is listening for a connection on port 8080

Hi Chris,

Astrotortilla and ansvr both use exactly the same version of, 0.38, so I’m not sure what would be the benefit of having ansvr use the astrotortilla instance. The original implementation of ansvr did in fact require and use an astrotortilla instance, but the separate installs turned out to be a maintenance and installation nightmare. Having a fully encapsulated dedicated instance has been by far more maintainable and supportable. is a set of command-line programs, and they never listen on any ports. Ansvr serves the function of listening on a port, running the command-line programs, and feeding the results back to SGP


Ah that’s how it works, thank you.

i tried it ,but unfortunately ansvar does not work today…have i to start ansvr.config or something else before i start SGPro?

Yep, just look on the sgpro forum and install ansvr which provides the back end of astrotortilla locally and makes it accessible from within sgpro. It works great, i use it as standard now.

Paul Kirk

Hi Chris

Would you mind sharing how you configured AT to use the existing location please?
I’d like to experiment with AT for polar alignment and seems silly to have two astrometry libraries when one is already working fine for me.


IIRC the main change was to set the Cygwin shell location to where ansvr put it, for me it is like this:

C:\Users\Chris\AppData\Local\cygwin_ansvr\bin\bash.exe --login -c "%s"

“Chris” is the user name, change this as appropriate.


Many thanks - will try it out next opportunity…

Thanks again Chris. I had been looking incorrectly to try and change the contents of the file in the first line, bu realised quickly I needed to be changing the cygwin location as you explained. Got it working off the ansvr install last night.

Alas, Astrotortilla doesn’t seem to play happily with my QHY9. I was hoping to use the polar alignment routines, but can only get it to work off saved files, even if SGP is closed and not using the camera. Worked ok on the guide camera (QHY5IIL) but too narrow FOV through an OAG.

I’m able to polar align fine with PHD2, but nothing the QHY9 problem in case anyone else “comes this way”.