New autofocus algorithm

Since the new autofocus algorithm was implemented and I unknowingly updated my SGP, it became super frustrating to use it. It fails almost every time, and I have to rerun AF multiple times until it hits that arbitrary magical 90% fit. Why can’t I adjust that number? what’s wrong with 89% and why does it fail? Can I revert back to the old algorithm without reverting whole SGP?

Moonlite focuser, Skywatcher Explorer 250PDS, SX694-Trius

These are my AF settings:

You can set the focus quality threshold, see SGP 3.1 Autofocus .


I may be wrong but with an exposure time of just 2 sec’s your going to be hard pushed to get any success at all, try pushing up your exposure time to around 6 sec’s and see what you get then.


1 Like

Thanks. I wonder why is this nowhere in documentation (or as something editable in settings). What other magic variables exist?

I have duration set filter-by-filter, so what you see is unused. but 2s is enough for LRGB, always worked with older algorithm.

You have ‘Auto Focus with Filter’ set to ‘L’ but the box is not checked to use the ‘L’ to focus, surely this checkbox should be checked ? ? ? ?


Temperature compensation threshold, see 353: Temp Comp - Set Min Threshold? .


There is a great tutorial in the SGP Help file regarding autofocus, specifically a formula to determine a good ballpark step size (I think yours may be too small as well as your exposure length). I followed the instructions there and have consistently achieved a good V-shaped curve and an accurate focus setting.

What is your V-curve looking like?

Try increasing your step size. I had similar troubles when the new algo was introduced and tried relaxing the quality threshold which helped a bit but in the end I doubled the step size and now get a good parabolic fit every time.

Yeah, I get excellent results on my SCT using 7 steps but a step size of 80 and using L primarily with an exposure of 2sec. I would think that a step size of 11 is too small for pretty much any focuser. I get it that it worked before, but you had to be on the edge and dependent more on the star quality and number in the FOV. Use a higher step size (dependent upon your focuser) and reduce the steps to 9 or 7 and you’ll get better results. Additionally, enable backlash compensation if not already done.

The step size seems small. I have a ML Nitecrawler and started my step size at 1500 to rough it in and after trial and error I have it down to 475.