Sequencer Window Scaling Issues

This issue is being reported in 4 different threads. Just consolidating here so that I don’t have to post potential fixes in all sorts of places.

Specifically, this new thread is a (single) continuation of any thread where the root of the problem is that your sequencer window looks like this:

What I meant is that you removed the ability to drag down the bottom Sequencer window frame bar (extend the window down) in and now the ability to do it has been restored. My impression was that you intentionally removed it to test the effect on the scaling issues and since it made no difference, restored it in I might be incorrect about the version number where that capability was missing.

But with the clues from your major successful progress in, I assume fixing the remaining problems should be “relatively” easy.

Right. Yes, 18 removed it, it made no difference and 19 restored it and made a different change (on the right track at least)


It seems you are on the right track. I did notice that when you click on the downward pointing triangles below the Target Data box and the Delay and Ordering box, things get messed up. More so, when you reclick them to minimize the dropdown, you don’t get the correct initial format. See attached.

So a little more info. In 1920x1080 mode, the window appears normal at scales of 100% and 150%, but the problem above occurs at 125%. In 4k mode everything seems to scale fine.


OK… Just an update here. It may have seemed like we were close with the limited release of, but I have decided that I am tired of not knowing what is going on, guessing at fixes or why we have this issue present itself in a seemingly random fashion. Because of this, I have taken a little timeout to try and actually understand, fundamentally, all the aspects of writing Windows apps for high resolution machines. In the end, despite nothing happening right now, it will actually probably be a faster, higher quality solution.

Stay tuned…

OK. Took 3 or so days, but I think I have a good solution in place. I’ll release that a little later tonight. I first wanted to post some stuff on the different ways Windows scales things and my opinion on them.

In W8 and W10 (and W7, but presented slightly differently) there are two different ways in which users can request “global scaling” across all apps.

The first way, to me, is the most straightforward and appealing. It scales controls, fonts and images proportionally and creates a larger, but proportional window, like this:

This method of scaling is called “Scale and Layout” (Desktop right click->Display Settings) and is achieved like this:

The second way is less clear to me. It is called “custom scaling”. Unlike the first method which indicates that if you set 150% you will be uniformly scaled to 150%, “custom scaling” at 150% will actually scale like the first method, but to 300%. Custom scaling at 150% would produce the reported issue. With the fix in place, high scaling values now produces an ugly, but (mostly) usable window like this (notice how the text starts clipping):

Custom scaling is achieved by clicking the “Custom scaling” link and then this:

It looks like SGPro can claim that it supports (nicely) scaling up to 200% and much higher if you are OK with those little clipping artifacts.

Version will reflect these changes (and vertical resizing of the sequencer was preserved)

@Ken, I don’t claim to be an expert on scaling, however, I did a few experiments and research. It appears the first method you describe is per monitor while the second is for all monitors (and is discouraged). I did not find the second setting gave double the value. It appears the two methods are independent which might mean that you had 150% for each method thus 300%

Ok, Ken, uncork the Champagne! works! It’s not perfect and as you predicted there are still a few minor scaling issues but it’s good enough. I tested most of the buttons and they seem to be operating properly. I even added a new event row and that works as does the vertical window stretch double arrow.

Attached is where you stand with W7 custom scaled at 130% on a 32" 4K monitor. From what you said above, those conditions may have presented the severest challenge in scaling the Sequencer window.

Thanks for all your efforts.

Yes, it seems that if you use “scale and layout” the formatting seems to work. Thanks!