ASI/ASCOM Connection Issue

Hi There,

I’ve not been imaging since March 2021, but I had no issues with Sequence Generator and my ASI equipment then.
Since then I have upgraded to the latest version of Sequence Generator, ASI drivers, and ASCOM version.
Tonight I was unable to get Sequence Generator to connect to my ASI equipment (ASI1600MM, ASI120MC, FW, and EAF). I can connect to all of them successfully with the ASCOM diagnostic software (see attached image).
For example, I will select the AIS Camera and then click on the configure tool. Then I get the following error message “Error getting properties dialog. Check DotNetExceptions ASCOM.ASICamera2_2.Camera SetupDialog System.TypeInitializationException: The type initializer for ‘TiFra.Diagnostic’ thre an exception.”
When I click on Connect I get the following error message “Error connecting to ASI Camera (2)!”

I have tried Sequence Generator Pro, Sequence Generator (32-bit), and Sequence Generator (64-bit). All have the same error.

PHD successfully connects to the ASI cameras using ASCOM. Was also able to use SharpCap to connect and use the cameras, but I think it uses the ASI driver and not the ASCOM driver.

I uninstaller all the drivers, the ASCOM software, and Sequence Generator. Then reinstalled everything, same issue.


  • Windows 11 64bit
  • ZWO_ASCOM_Setup_V6.5.2
  • ZWO_ASI_Cameras_driver_Setup_V3.18
  • ASCOM Platform 6.6
  • Sequence Generator Pro, Sequence Generator (32-bit), and Sequence Generator (64-bit)

Any guidance please.

Screenshots from ASCOM Diagnostic Software:

Error messages from SGP:

20220427 Sequence Generator Connect Error

I started having the same exact issue.

Very similar issue, my Planewave focuser isn’t connecting now. I can connect to the focuser directly with the Planewave software, I can also connect via TheSkyX, but since yesterday when trying via SGP I’m receiving “Error cannot connect to Planewave Focuser (PWI3).” It’s worked flawlessly for 3 years.
Tried the usual fixes, i even downgraded back to Win10, and an earlier SGP version, but to no avail.

We are more than happy to see if your logs produce any additional data and if you want to send them, we’ll take a look.

This solved the problem for me:

In Windows 11 Settings go to:

  1. Apps > Optional features
  2. Find and click on “Related settings / More Windows features”
  3. Enable the features under .NET Framework 3.5

Screenshot 2022-04-30 092240

1 Like

Tried it and it worked. Was able to connect to the Camera, Filter Wheel, and Focuser.

Strange solution though.

Thanks a million!!

I found the hint here:
Screenshot 2022-04-30 160059

1 Like

Thanks for the feedback here. We absolutely think you should follow the ASCOM recommendations, but the fact remains though, that other ASCOM connections seemed OK and SGPro did not. I think that this might be due to some odd config settings stored in SGPro that other ASCOM things might pick up on and try to initialize a thing you don’t have installed. It’s hard to tell for sure, but I think that those weird config stuff that some drivers pick up on has been removed.

But, as @kentberry noted, it stands to reason that the normal operation of a driver is still within bounds to attempt to use something that requires .NET 3.5. In this case, the “failure” will just be moved from connection to some later time during use.

1 Like